dbus_agldemo: Fix recipe style error 63/27563/1
authorduerpei <duep.fnst@fujitsu.com>
Fri, 27 May 2022 02:59:12 +0000 (10:59 +0800)
committerduerpei <duep.fnst@fujitsu.com>
Fri, 27 May 2022 02:59:12 +0000 (10:59 +0800)
The bitbake recipe has style guide at
https://www.openembedded.org/wiki/Styleguide

In do_install
Don't use mkdir to create destination directories,
use install -d instead.

Bug-AGL: SPEC-4401

Signed-off-by: duerpei <duep.fnst@fujitsu.com>
Change-Id: If5a9331532d9777cad1c0f55d8a1105932e97872

recipes-core/dbus/dbus_agldemo.inc

index 193db5d..826584c 100644 (file)
@@ -16,7 +16,7 @@ do_install:append() {
 
             # Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
             # because it does not support systemd's user mode.
-            mkdir -p ${D}${sysconfdir}/systemd/user/default.target.wants/
+            install -d ${D}${sysconfdir}/systemd/user/default.target.wants/
             ln -sf ${systemd_user_unitdir}/dbus.socket ${D}${sysconfdir}/systemd/user/default.target.wants/dbus.socket
         fi
     fi