Add flutter dashboard app 97/27897/4
authorHritik Chouhan <hritikc3961@gmail.com>
Wed, 10 Aug 2022 20:27:34 +0000 (22:27 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 7 Sep 2022 16:24:43 +0000 (16:24 +0000)
- This adds the Flutter dashboard app in the AGL.
- Pin the flutter dashboard app in IVI flutter demo homescreen.
- Integrate with kuksa-val server.
- change the homepage same as SRC_URI.
- change the AGL_APP_NAME.

Bug-AGL: SPEC-4524

Change-Id: I37dbcac2aa7a26b64250dd8fbec4de6051f16198
Signed-off-by: Hritik Chouhan <hritikc3961@gmail.com>
recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb [new file with mode: 0644]
recipes-demo/flutter-hvac/flutter-app-hvac_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb

diff --git a/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb b/recipes-demo/flutter-dashboard/flutter-app-dashboard_git.bb
new file mode 100644 (file)
index 0000000..822bb80
--- /dev/null
@@ -0,0 +1,30 @@
+SUMMARY = "Flutter Dashboard"
+DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
+
+HOMEPAGE = "https://github.com/hritik-chouhan/dashboard_for_recipe"
+
+BUGTRACKER = "https://github.com/hritik-chouhan/dashboard_for_recipe/issues"
+
+SECTION = "graphics"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
+
+
+SRC_URI = "git://github.com/hritik-chouhan/dashboard_for_recipe.git;protocol=https;branch=main"
+SRCREV = "c3234da907ff46fb113f308b5ab257089fdcab4f"
+S = "${WORKDIR}/git"
+
+inherit agl-app flutter-app
+
+# flutter-app
+#############
+PUBSPEC_APPNAME = "dashboard_app"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+# agl-app
+#########
+AGL_APP_TEMPLATE = "agl-app-flutter"
+AGL_APP_ID = "dashboard_app"
+AGL_APP_NAME = "Flutter Dashboard"
diff --git a/recipes-demo/flutter-hvac/flutter-app-hvac_git.bb b/recipes-demo/flutter-hvac/flutter-app-hvac_git.bb
new file mode 100644 (file)
index 0000000..eadf642
--- /dev/null
@@ -0,0 +1,30 @@
+SUMMARY = "Flutter HVAC"
+DESCRIPTION = "A Flutter based IVI Dashboard Application for automotive grade Linux."
+
+HOMEPAGE = "https://github.com/hritik-chouhan/HVAC_dashboard"
+
+BUGTRACKER = "https://github.com/hritik-chouhan/HVAC_dashboard/issues"
+
+SECTION = "graphics"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://License.md;md5=f712ede8d4f845976061925d1416fc40"
+
+
+SRC_URI = "git://github.com/hritik-chouhan/HVAC_dashboard.git;protocol=https;branch=main"
+SRCREV = "0f9b82048e867afde53bd72b4736511dae8d09ff"
+S = "${WORKDIR}/git"
+
+inherit agl-app flutter-app
+
+# flutter-app
+#############
+PUBSPEC_APPNAME = "flutter_hvac"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+# agl-app
+#########
+AGL_APP_TEMPLATE = "agl-app-flutter"
+AGL_APP_ID = "flutter_hvac"
+AGL_APP_NAME = "Flutter Hvac"
index 747fb6f..eb7907a 100644 (file)
@@ -20,7 +20,8 @@ RDEPENDS:${PN} += "\
 AGL_APPS = " \
     hvac \
     dashboard \
-    flutter-gallery-runtimerelease \
+    flutter-app-dashboard \
+    flutter-app-hvac \
     "
 
 RDEPENDS:${PN}:append = " \