wam: fix surface type name in application manifest 75/27975/1
authorJose Dapena Paz <jdapena@igalia.com>
Wed, 31 Aug 2022 10:24:55 +0000 (12:24 +0200)
committerJose Dapena Paz <jdapena@igalia.com>
Tue, 6 Sep 2022 15:12:17 +0000 (17:12 +0200)
Renamed appinfo.json field surface_role to be surface_type to be
consistent with other parts of the code base. Took the chance to remove
types that were not meaningful, and renamed default type (the one used
when it is not set) to be default instead of none.

Then updated the only applications setting the value to use the new
propery. Those are html5-background and html5-homescreen.

wam: 8ea41f7..4fbd6e6
4fbd6e6 [op][agl][wayland] Provide only supported AGL shell types

html5-background: e91be22..aa7e2a8
aa7e2a8 Rename surface/role in appinfo.json to surface/type.
bb4f497 autobuild: Remove autobuild scripts

html-homescreen: fc0ffa4..f3cecb6
f3cecb6 Rename surface/role in appinfo.json to surface/type.

Bug-AGL: SPEC-4505
Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
Change-Id: I404717dd5d848220bd5f070b98de56df38a78e20

recipes-demo/html5-background/html5-background_git.bb
recipes-demo/html5-homescreen/html5-homescreen_git.bb
recipes-wam/wam/wam_git.bb

index 656923a..4e6bb14 100644 (file)
@@ -11,7 +11,7 @@ B       = "${WORKDIR}/build"
 SRC_URI = " \
   git://gerrit.automotivelinux.org/gerrit/apps/html5-background;protocol=https;branch=master \
 "
-SRCREV = "e91be225127ddea6be3ddae5cb35e88c2f0aafb8"
+SRCREV = "aa7e2a81e91ed076c0bc9ba07db5aee0f34668df"
 
 inherit pythonnative agl-app
 
index 65de729..1be9751 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI = " \
   git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=master \
   file://homescreen.service \
 "
-SRCREV = "fc0ffa4c45d3a6ec6ad8cc9b939ef6c9dd2e7eaf"
+SRCREV = "f3cecb6e79d7fcac14535108c06cb5a922159d78"
 
 inherit pythonnative
 
index f1bb666..4b640d5 100644 (file)
@@ -30,7 +30,7 @@ SRC_URI = "\
     file://WebAppMgr.env \
 "
 S = "${WORKDIR}/git"
-SRCREV = "8ea41f7b59b52ef005f6f932e3335bfd137aa5fa"
+SRCREV = "4fbd6e648913bcf0fba63e4460eb44242c11f71b"
 
 PV = "ose58.agl"