Add AGL libqtappfw to the platform
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo.bb
1 SUMMARY = "The software for AGL IVI DEMO profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PACKAGES = "\
9     packagegroup-agl-demo \
10     "
11
12 ALLOW_EMPTY_${PN} = "1"
13
14 SMARTDEVICELINK = "${@bb.utils.contains('DISTRO_FEATURES', 'agl-sdl', \
15     'packagegroup-agl-smartdevicelink', '', d)}"
16
17 # old homescreen package
18 HOMESCREEN-OLD = "homescreen"
19 # packages from hmi-framework aka homescreen-2017
20 HOMESCREEN-NEW = "packagegroup-hmi-framework packagegroup-hmi-framework-dev"
21
22 RDEPENDS_${PN} += "\
23     packagegroup-agl-appfw \
24     libqtappfw \
25     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-hmi-framework', '${HOMESCREEN-NEW}', '${HOMESCREEN-OLD}', d)} \
26     udisks \
27     ${SMARTDEVICELINK} \
28     "
29
30 # fonts
31 TTF_FONTS = " \
32     ttf-bitstream-vera \
33     ttf-dejavu-sans \
34     ttf-dejavu-sans-mono \
35     ttf-dejavu-serif \
36     "
37
38 # Add webkit as workaround as webengine is broken right now
39 EXTRA_APPS_append = " qtwebkit qtwebkit-examples-examples"
40 #EXTRA_APPS_append = " qtsmarthome cinematicexperience qt5everywheredemo qt5-demo-extrafiles"
41 #IMAGE_INSTALL_append = " qtwebengine-examples"
42
43 # add support for websocket in Qt and QML
44 EXTRA_APPS_append = " qtwebsockets qtwebsockets-qmlplugins"
45 PREFERRED_PROVIDER_virtual/webruntime = "web-runtime"
46
47
48 RDEPENDS_${PN} += " \
49     linux-firmware-ath9k \
50     can-utils \
51     iproute2 \
52     python-curses \
53     dhcp-client \
54     ${TTF_FONTS} \
55     ${EXTRA_APPS} \
56     "