Prepare master for new framework integration
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform-html5.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PROVIDES = "${PACKAGES}"
9 PACKAGES = "\
10     packagegroup-agl-demo-platform-html5 \
11     packagegroup-agl-demo-platform-html5-devel \
12     "
13
14 ALLOW_EMPTY:${PN} = "1"
15
16 RDEPENDS:${PN} += "\
17     packagegroup-agl-image-ivi \
18     "
19
20 RDEPENDS:${PN} += "\
21     packagegroup-hmi-framework \
22     "
23
24
25 RDEPENDS:${PN}:append = " \
26     weston-ini-conf \
27     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
28     "
29
30 # NOTE: Currently no coverage versions for the application widgets,
31 #       they should be added here when available.
32 #       Also, the navigation and mixer debug widgets are currently
33 #       specified explicitly, as there's no simple way to derive their
34 #       names from the virtual/ RPROVIDES at present.
35 RDEPENDS:${PN}-devel = " \
36     packagegroup-hmi-framework-devel \
37     "