agl-demo: update meta-clang comment
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform-html5.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PROVIDES = "${PACKAGES}"
9 PACKAGES = "\
10     packagegroup-agl-demo-platform-html5 \
11     "
12
13 RDEPENDS:${PN} += "\
14     packagegroup-agl-demo \
15     "
16
17 # TODO(jdapena): replace this with HTML5 apps.
18 AGL_APPS = " \
19     html5-dashboard \
20     html5-launcher \
21     html5-homescreen \
22     html5-hvac \
23     html5-mediaplayer \
24     html5-mixer \
25     html5-settings \
26     html5-aquarium \
27     html5-youtube \
28     html5-jitsi \
29     html5-examples \
30     "
31
32 RDEPENDS:${PN}:append = " \
33     wam \
34     weston-ini-conf-landscape-no-activate \
35     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
36     qtquickcontrols2-agl \
37     qtquickcontrols2-agl-style \
38     ${AGL_APPS} \
39     "
40
41 # nss-agl-driver-db is required to connect to kuksa
42 RDEPENDS:${PN}:append = " nss-agl-driver-db "
43