Rework nss-agl-driver-db to be a systemd unit at runtime
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform-html5.bb
1 SUMMARY = "The software for DEMO platform of AGL IVI profile"
2 DESCRIPTION = "A set of packages belong to AGL Demo Platform"
3
4 LICENSE = "MIT"
5
6 inherit packagegroup
7
8 PROVIDES = "${PACKAGES}"
9 PACKAGES = "\
10     packagegroup-agl-demo-platform-html5 \
11     "
12
13 RDEPENDS:${PN} += "\
14     packagegroup-agl-image-ivi \
15     packagegroup-agl-profile-graphical-html5 \
16     packagegroup-agl-demo \
17     "
18
19 # TODO(jdapena): replace this with HTML5 apps.
20 AGL_APPS = " \
21     html5-dashboard \
22     html5-launcher \
23     html5-homescreen \
24     html5-hvac \
25     html5-mediaplayer \
26     html5-mixer \
27     html5-settings \
28     html5-aquarium \
29     html5-youtube \
30     html5-jitsi \
31     html5-examples \
32     "
33
34 RDEPENDS:${PN}:append = " \
35     weston-ini-conf-landscape-no-activate \
36     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
37     qtquickcontrols2-agl \
38     qtquickcontrols2-agl-style \
39     ${AGL_APPS} \
40     "
41
42 # nss-agl-driver-db is required to connect to kuksa
43 RDEPENDS:${PN}:append = " nss-agl-driver-db "
44