Update inclusion in agl-demo-platform-crosssdk for openssh change
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-image-ivi.bb
1 SUMMARY = "A basic system of AGL distribution of IVI profile"
2
3 DESCRIPTION = "Basic image for baseline of AGL Distribution for IVI profile."
4
5 LICENSE = "MIT"
6
7 require recipes-platform/images/agl-image-weston.inc
8
9 IMAGE_INSTALL:append = "\
10     packagegroup-agl-image-ivi \
11     packagegroup-agl-ivi-services \
12     ${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'packagegroup-pipewire', '', d)} \
13     can-utils \
14     iproute2 \
15     "
16
17 IMAGE_FEATURES += "splash package-management ssh-server-openssh"
18
19 # NOTE: In hardknott or later this can be replaced by adding "weston"
20 #       to IMAGE_FEATURES.
21 SYSTEMD_DEFAULT_TARGET = "graphical.target"
22
23