Add nativesdk-wayland to the SDK
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
1 SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
2
3 DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
4 It includes the full meta-toolchain, plus developement headers and libraries \
5 to form a standalone cross SDK."
6
7 require agl-demo-platform.bb
8
9 LICENSE = "MIT"
10
11 IMAGE_FEATURES_append = " dev-pkgs"
12 IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
13
14 inherit populate_sdk populate_sdk_qt5
15
16 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
17 # Both exec "createrepo" on the same directory, and so one of them
18 # can failed (randomly).
19 addtask do_populate_sdk after do_rootfs
20
21 # native tools to support Chromium build inside SDK (SPEC-942)
22 TOOLCHAIN_HOST_TASK += " \
23     nativesdk-gn \
24     nativesdk-ninja \
25     nativesdk-gperf \
26     nativesdk-zlib \
27     nativesdk-xz \
28     nativesdk-nspr-dev \
29     nativesdk-nss-dev \
30     "
31
32 # required dependencies for Chromium build inside SDK (SPEC-942)
33 TOOLCHAIN_TARGET_TASK += " \
34     pciutils-dev \
35     pulseaudio-dev \
36     cairo-dev \
37     nss-dev \
38     cups-dev \
39     gconf-dev \
40     libexif-dev \
41     pango-dev \
42     libdrm-dev  \
43     libssp-dev \
44     ffmpeg-dev \
45     "
46
47 # Add wayland-scanner to SDK (SPEC-945)
48 # Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
49 # wayland-scanner is in nativesdk-wayland-dev !
50 # option: add also nativesdk-qtwayland-tools
51 TOOLCHAIN_HOST_TASK_append = " nativesdk-wayland nativesdk-wayland-dev"