ondemandnavi: remove org.agl.naviapi.conf from recipe
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / mapviewer_%.bbappend
1 FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
2
3 SRC_URI_append = "\
4     file://mapviewer-settings.sh \
5     file://mapviewer.service \
6 "
7
8 inherit systemd
9
10 SYSTEMD_PACKAGES = "${PN}"
11
12 do_install_append() {
13     install -d ${D}${prefix}/AGL/${PN}
14     install -m 0755 ${WORKDIR}/mapviewer-settings.sh ${D}${prefix}/AGL/${PN}/
15
16     # Install systemd unit file
17     if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
18         install -d ${D}${systemd_system_unitdir}
19         install -m 644 ${WORKDIR}/mapviewer.service ${D}${systemd_system_unitdir}/mapviewer.service
20     fi
21 }
22
23 SYSTEMD_SERVICE_${PN} = "mapviewer.service"
24
25 FILES_${PN} += "${prefix}/AGL/${PN}/"