ondemandnavi: remove org.agl.naviapi.conf from recipe 19/23019/2
authorMatt Ranostay <matt.ranostay@konsulko.com>
Tue, 12 Nov 2019 05:02:11 +0000 (07:02 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 27 Nov 2019 16:10:03 +0000 (16:10 +0000)
agl-service-navigation uses the afb framework and application
doesn't need DBus access anymore.

Bug-AGL: SPEC-2880
Change-Id: Ie381eff74cc4f053a02fe4e56f9fadc3cf191235
Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
(cherry picked from commit 94d43cc23ef59dcce4912323e19c31247126c101)

recipes-demo-hmi/navigation/ondemandnavi/org.agl.naviapi.conf [deleted file]
recipes-demo-hmi/navigation/ondemandnavi_git.bb

diff --git a/recipes-demo-hmi/navigation/ondemandnavi/org.agl.naviapi.conf b/recipes-demo-hmi/navigation/ondemandnavi/org.agl.naviapi.conf
deleted file mode 100755 (executable)
index 7f4d85f..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-<!DOCTYPE busconfig PUBLIC
-"-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
-"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
-<busconfig>
-       <policy context="default">
-               <!-- Allow everyone to talk to main service. We'll later add an agent to
-                    only share the location if user allows it. -->
-               <allow send_interface="org.agl.naviapi"/>
-       </policy>
-
-       <policy user="root">
-               <!-- Allow root to own the name on the bus -->
-               <allow own="org.agl.naviapi"/>
-       </policy>
-</busconfig>
index 82f0ce8..a2c79b8 100644 (file)
@@ -17,20 +17,13 @@ DEPENDS += "qtbase \
 
 PV = "1.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH} \
-           file://org.agl.naviapi.conf \
-"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
 
 S = "${WORKDIR}/git"
 
 inherit qmake5 aglwgt pkgconfig
 
-do_install_append() {
-   install -d ${D}/etc/dbus-1/session.d/
-   install -m 0644 ${WORKDIR}/org.agl.naviapi.conf ${D}/etc/dbus-1/session.d/
-}
-
 RDEPENDS_${PN} += "qtlocation \
                    flite \
                    libqtappfw \