Add AGL libqtappfw to the platform
[AGL/meta-agl-demo.git] / recipes-demo-hmi / libqtappfw / libqtappfw_git.bb
1 SUMMARY     = "AGL Qt AppFW Library"
2 DESCRIPTION = "libqtappfw"
3 HOMEPAGE    = "http://docs.automotivelinux.org"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "libs"
6
7 BBCLASSEXTEND = " nativesdk"
8
9 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
10
11 DEPENDS += " qtbase qtwebsockets "
12
13 inherit cmake_qt5
14
15 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
16 SRCREV  = "112fc8be473f02befc7596750ad7044113f29849"
17 S       = "${WORKDIR}/git/"
18
19 # PV needs to be modified with SRCPV to work AUTOREV correctly
20 PV = "0.0+git${SRCPV}"
21
22 FILES_${PN} = "\
23         ${libdir}/libqtappfw.so.* \
24 "
25 FILES_${PN}-dev = "\
26         ${includedir}/qtappfw/message.h \
27         ${includedir}/qtappfw/messageengine.h \
28         ${includedir}/qtappfw/telephonymessage.h \
29         ${includedir}/qtappfw/telephony.h \
30         ${libdir}/libqtappfw.so \
31         ${libdir}/pkgconfig/qtappfw.pc \
32 "
33 FILES_${PN}-dbg += "\
34         ${libdir}/.debug/libqtappfw.so.* \
35 "