Add recipe of AGL Demo HMI (HVAC)
[AGL/meta-agl-demo.git] / recipes-demo-hmi / hvac / hvac_git.bb
1 SUMMARY     = "HVAC for CES2017 AGL Demonstration"
2 DESCRIPTION = "AGL HMI Application for demonstrating HVAC on AGL Distribution"
3 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/hvac"
4 LICENSE     = "Apache-2.0"
5 SECTION     = "apps"
6
7 PV = "1.0+git${SRCPV}"
8 S  = "${WORKDIR}/git"
9
10 inherit qmake5
11
12 # 'wgtpkg-pack' in af-main-native is required.
13 DEPENDS = "af-main-native"
14
15 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
16
17 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=http"
18 SRCREV  = "${AUTOREV}"
19
20 RDEPENDS_${PN} += " \
21     qtmultimedia-qmlplugins \
22     qtquickcontrols2-qmlplugins \
23     "
24
25 do_install() {
26     install -d ${D}/usr/AGL/apps
27     install -m 0644 ${B}/package/${PN}.wgt ${D}/usr/AGL/apps/
28 }
29
30 FILES_${PN} += "/usr/AGL/apps/ \
31     /usr/AGL/apps/${PN} \
32     "