Add recipe of AGL Demo HMI (HVAC) 85/7685/2
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Sun, 18 Dec 2016 14:51:08 +0000 (23:51 +0900)
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Mon, 19 Dec 2016 10:53:26 +0000 (10:53 +0000)
This recipe is to deliver AGL Demo Platform for
CES2017 AGL Showcase by bitbake integration.

To use hmi of HVAC,  it should be installed on the target
board at least once afer booting.

The package of application, hvac.wgt would be installed
in /usr/AGL/apps on the target board.

To install it, follow these steps from the target console
or remote shell.
  # cd /usr/AGL/apps
  # afm-util install hvac.wgt

Change-Id: I4d90dcae44fc6a5bedf2b26682ae2dcbfd4db6ee
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
recipes-demo-hmi/hvac/hvac_git.bb [new file with mode: 0644]

diff --git a/recipes-demo-hmi/hvac/hvac_git.bb b/recipes-demo-hmi/hvac/hvac_git.bb
new file mode 100644 (file)
index 0000000..f5d4537
--- /dev/null
@@ -0,0 +1,32 @@
+SUMMARY     = "HVAC for CES2017 AGL Demonstration"
+DESCRIPTION = "AGL HMI Application for demonstrating HVAC on AGL Distribution"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/hvac"
+LICENSE     = "Apache-2.0"
+SECTION     = "apps"
+
+PV = "1.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
+
+inherit qmake5
+
+# 'wgtpkg-pack' in af-main-native is required.
+DEPENDS = "af-main-native"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/hvac;protocol=http"
+SRCREV  = "${AUTOREV}"
+
+RDEPENDS_${PN} += " \
+    qtmultimedia-qmlplugins \
+    qtquickcontrols2-qmlplugins \
+    "
+
+do_install() {
+    install -d ${D}/usr/AGL/apps
+    install -m 0644 ${B}/package/${PN}.wgt ${D}/usr/AGL/apps/
+}
+
+FILES_${PN} += "/usr/AGL/apps/ \
+    /usr/AGL/apps/${PN} \
+    "