pipewire: Update PipeWire to v0.3.83 and WirePlumber to v0.4.15
[AGL/meta-agl.git] / meta-app-framework / recipes-core / applaunchd / applaunchd_git.bb
index 27f1af8..c1bafad 100644 (file)
@@ -25,11 +25,20 @@ SRC_URI = " \
     file://no-network.conf \
     file://private-tmp.conf \
 "
-SRCREV = "5cab14e6a98519e0b6c6043a1a19e42f094d6522"
+SRCREV = "c32fe42f40d0af8b31b6113a3140f52b83be7769"
 
 S = "${WORKDIR}/git"
 
-inherit meson pkgconfig systemd
+inherit meson pkgconfig systemd useradd features_check
+
+REQUIRED_DISTRO_FEATURES = "systemd polkit"
+
+USERADD_PACKAGES = "${PN}"
+USERADDEXTENSION = "useradd-staticids"
+GROUPADD_PARAM:${PN} = "-g 1003 applaunchd ; "
+USERADD_PARAM:${PN} = "\
+    -g 1003 -u 1003 -o -d / -K PASS_MAX_DAYS=-1 applaunchd ; \
+"
 
 SYSTEMD_SERVICE:${PN} = "applaunchd.service"
 
@@ -49,7 +58,7 @@ do_install:append() {
 
 PACKAGE_BEFORE_PN += "${PN}-template-agl-app ${PN}-template-agl-app-web ${PN}-template-agl-app-flutter"
 
-FILES:${PN} += "${systemd_system_unitdir} ${datadir}/dbus-1/"
+FILES:${PN} += "${systemd_system_unitdir}"
 
 FILES:${PN}-template-agl-app = "${systemd_system_unitdir}/agl-app@.service"
 
@@ -58,7 +67,7 @@ FILES:${PN}-template-agl-app-web = "${systemd_system_unitdir}/agl-app-web@.servi
 FILES:${PN}-template-agl-app-flutter = "${systemd_system_unitdir}/agl-app-flutter@.service"
 
 RDEPENDS:${PN} += " \
-    agl-session \
+    agl-users \
     polkit-rule-agl-app \
 "