Packaging: ignore expected rpmlint warnings
[src/xds/xds-gdb.git] / conf.d / packaging / rpm / agl-xds-gdb.spec
1 #
2 # spec file for package agl-xds-gdb
3 #
4
5 %define _prefix /opt/AGL
6 %global debug_package %{nil}
7
8 Name:           agl-xds-gdb
9 Version:        0.0.0
10 Release:        0
11 License:        Apache-2.0
12 Summary:        Wrapper on gdb debugger for XDS
13 Url:            https://gerrit.automotivelinux.org/gerrit/p/src/xds/xds-gdb.git
14 Source0:        xds-gdb_linux-amd64-%{version}.zip
15 Source1:        rpmlintrc
16 BuildRequires:  unzip
17 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
18 Group:          Development/Tools/Debuggers
19
20 %description
21 xds-gdb is an agent that should run on your local machine when you use XDS
22
23 %prep
24 %setup -q -n xds-gdb
25
26 %build
27
28 %install
29 mkdir -p %{?buildroot}%{_prefix}/xds/gdb %{?buildroot}%{_bindir}
30 cp xds-gdb %{?buildroot}%{_prefix}/xds/gdb
31 ln -s ../xds/gdb/xds-gdb %{?buildroot}%{_bindir}/xds-gdb
32
33 mkdir -p %{?buildroot}%{_sysconfdir}/profile.d
34 sed -e "s;@XDS_INSTALL_BIN_DIR@;%{_bindir};g" ./conf.d/etc/profile.d/xds-gdb.sh > %{buildroot}%{_sysconfdir}/profile.d/%{name}.sh
35
36 %files
37 %defattr(-,root,root)
38 %dir %{_prefix}
39 %dir %{_bindir}
40 %dir %{_prefix}/xds
41 %dir %{_prefix}/xds/gdb
42 %{_prefix}/xds/gdb/*
43 %{_bindir}/xds-gdb
44 %config %{_sysconfdir}/profile.d/%{name}.sh
45 %attr(644,root,root) %{_sysconfdir}/profile.d/%{name}.sh