Packaging: ignore expected rpmlint warning
[src/xds/xds-cli.git] / conf.d / packaging / rpm / agl-xds-cli.spec
1 #
2 # spec file for package agl-xds-cli
3 #
4
5 %define _prefix /opt/AGL
6 %global debug_package %{nil}
7
8 Name:           agl-xds-cli
9 Version:        0.0.0
10 Release:        0
11 License:        Apache-2.0
12 Summary:        Command line tool to interact with XDS
13 Url:            https://gerrit.automotivelinux.org/gerrit/p/src/xds/xds-cli.git
14 Source0:        xds-cli_linux-amd64-%{version}.zip
15 Source1:        rpmlintrc
16 BuildRequires:  unzip
17 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
18 Group:          Development/Tools/Debuggers
19
20 %description
21 xds-cli is a client tool that should be used to interact with an XDS server.
22
23 %prep
24 %setup -q -n xds-cli
25
26 %build
27
28 %install
29 mkdir -p %{?buildroot}%{_prefix}/xds/cli %{?buildroot}%{_bindir}
30 cp xds-cli %{?buildroot}%{_prefix}/xds/cli
31 ln -s ../xds/cli/xds-cli %{?buildroot}%{_bindir}/xds-cli
32
33 mkdir -p %{?buildroot}%{_sysconfdir}/bash_completion.d
34 cp ./conf.d/etc/bash_completion.d/xds-cli %{?buildroot}%{_sysconfdir}/bash_completion.d/
35
36 mkdir -p %{?buildroot}%{_sysconfdir}/profile.d
37 sed -e "s;@XDS_INSTALL_BIN_DIR@;%{_bindir};g" ./conf.d/etc/profile.d/xds-cli.sh > %{buildroot}%{_sysconfdir}/profile.d/%{name}.sh
38
39 %files
40 %defattr(-,root,root)
41 %dir %{_prefix}
42 %dir %{_bindir}
43 %dir %{_prefix}/xds
44 %dir %{_prefix}/xds/cli
45 %{_prefix}/xds/cli/*
46 %{_bindir}/xds-cli
47 %attr(644,root,root) %{_sysconfdir}/bash_completion.d/xds-cli
48 %config %{_sysconfdir}/profile.d/%{name}.sh
49 %attr(644,root,root) %{_sysconfdir}/profile.d/%{name}.sh