bf4e9b5b084d8453198ea8fa38ca181cd6d303e1
[src/app-framework-binder.git] / conf.d / packaging / rpm / agl-app-framework-binder.spec
1 #
2 # spec file for package app-framework-binder
3 #
4
5 %define _prefix /opt/AGL
6 %define __cmake cmake
7
8 Name:           agl-app-framework-binder
9 # WARNING {name} is not used for tar file name in source nor for setup
10 #         Check hard coded values required to match git directory naming
11 Version:        2.0
12 Release:        0
13 License:        Apache-2.0
14 Summary:        AGL app-framework-binder
15 Group:          Development/Libraries/C and C++
16 Url:            https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-binder
17 Source:         app-framework-binder-%{version}.tar.gz
18 #BuildRequires:  gdb
19 BuildRequires:  pkgconfig(libmicrohttpd) >= 0.9.55
20 BuildRequires:  make
21 BuildRequires:  cmake
22 BuildRequires:  pkgconfig(libsystemd) >= 222
23 BuildRequires:  pkgconfig(openssl)
24 BuildRequires:  pkgconfig(uuid)
25 BuildRequires:  libgcrypt-devel
26 BuildRequires:  pkgconfig(gnutls)
27 BuildRequires:  pkgconfig(json-c)
28 BuildRequires:  file-devel
29 BuildRequires:  gcc-c++
30
31 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
32
33 %description
34 Provides a test agl binder service which can be used to test agl bindings on Linux PC
35 This service is evolving permanently and is only designed as a helper for developper.
36
37 %package devel
38 Group:          Development/Libraries/C and C++
39 Requires:       %{name} = %{version}
40 Provides:       pkgconfig(%{name}) = %{version}
41 Summary:        AGL app-framework-binder-devel
42 %description devel
43 Provides a test agl binder service which can be used to test agl bindings on Linux PC
44 This service is evolving permanently and is only designed as a helper for developper.
45
46
47 %prep
48 %setup -q -n app-framework-binder-%{version}
49
50 %build
51 export PKG_CONFIG_PATH=%{_libdir}/pkgconfig
52 %cmake  -DAGL_DEVEL=1 -DINCLUDE_MONITORING=ON
53 %__make %{?_smp_mflags}
54
55
56 %install
57 [ -d build ] && cd build
58 %make_install
59
60 mkdir -p %{buildroot}%{_sysconfdir}/profile.d
61 cat << EOF > %{buildroot}%{_sysconfdir}/profile.d/AGL-%{name}.sh
62 #----------  AGL %%{name} options Start ---------"
63 # Object: AGL cmake option for  binder/bindings
64 export LD_LIBRARY_PATH=%{_libdir}:\${LD_LIBRARY_PATH}
65 export LIBRARY_PATH=%{_libdir}:\${LIBRARY_PATH}
66 export PKG_CONFIG_PATH=%{_libdir}/pkgconfig:\${PKG_CONFIG_PATH}
67 export PATH=%{_bindir}:\$PATH
68 #----------  AGL options End ---------
69 EOF
70
71 %post
72
73 %postun
74
75 %files
76 %defattr(-,root,root)
77 %dir %{_bindir}
78 %{_bindir}/afb-client-demo
79 %{_bindir}/afb-daemon
80 %{_bindir}/afb-genskel
81 %{_bindir}/afb-exprefs
82 %{_bindir}/afb-json2c
83
84 %dir %{_libdir}
85 %dir %{_libdir}/afb
86 %{_libdir}/libafbwsc.so.1
87 %{_libdir}/libafbwsc.so.1.1
88
89 #app-framework-binder demo
90 %{_libdir}/afb/*.so
91 %config(noreplace) %{_sysconfdir}/profile.d/AGL-%{name}.sh
92
93 #app-framework-binder monitoring
94 %dir %{_libdir}/afb/monitoring
95 %{_libdir}/afb/monitoring/*
96
97 %files devel
98 %defattr(-,root,root)
99 %dir %{_prefix}
100 %{_libdir}/libafbwsc.so
101 %dir %{_includedir}
102 %dir %{_includedir}/afb
103 %{_includedir}/afb/*
104 %dir %{_libdir}/pkgconfig
105 %{_libdir}/pkgconfig/*.pc
106
107 %changelog
108 * Wed Sep 27 2017 Dominig
109 - move to git repo
110 * Tue Aug 01 2017 Ronan
111 - initial creation