packaging: update dependency on libmicrohttpd version
[src/app-framework-binder.git] / conf.d / packaging / rpm / agl-app-framework-binder.spec
1 #
2 # spec file for package app-framework-binder
3 #
4
5 %define _prefix /opt/AGL
6 %define __cmake cmake
7
8 Name:           agl-app-framework-binder
9 # WARNING {name} is not used for tar file name in source nor for setup
10 #         Check hard coded values required to match git directory naming
11 Version:        2.0
12 Release:        0
13 License:        Apache-2.0
14 Summary:        AGL app-framework-binder
15 Group:          Development/Libraries/C and C++
16 Url:            https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-binder
17 Source:         app-framework-binder-%{version}.tar.gz
18 #BuildRequires:  gdb
19 BuildRequires:  pkgconfig(libmicrohttpd) >= 0.9.62
20 BuildRequires:  make
21 BuildRequires:  cmake
22 BuildRequires:  pkgconfig(libsystemd) >= 222
23 BuildRequires:  pkgconfig(openssl)
24 BuildRequires:  pkgconfig(uuid)
25 BuildRequires:  libgcrypt-devel
26 BuildRequires:  pkgconfig(gnutls)
27 BuildRequires:  pkgconfig(json-c)
28 BuildRequires:  file-devel
29 BuildRequires:  gcc-c++
30
31 Requires:       libmicrohttpd >= 0.9.62
32
33 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
34
35 %description
36 Provides a test agl binder service which can be used to test agl bindings on Linux PC
37 This service is evolving permanently and is only designed as a helper for developper.
38
39 %package devel
40 Group:          Development/Libraries/C and C++
41 Requires:       %{name} = %{version}
42 Provides:       pkgconfig(%{name}) = %{version}
43 Summary:        AGL app-framework-binder-devel
44 %description devel
45 Provides a test agl binder service which can be used to test agl bindings on Linux PC
46 This service is evolving permanently and is only designed as a helper for developper.
47
48
49 %prep
50 %setup -q -n app-framework-binder-%{version}
51
52 %build
53 export PKG_CONFIG_PATH=%{_libdir}/pkgconfig
54 %cmake  -DAGL_DEVEL=1 -DINCLUDE_MONITORING=ON
55 %__make %{?_smp_mflags}
56
57
58 %install
59 [ -d build ] && cd build
60 %make_install
61
62 mkdir -p %{buildroot}%{_sysconfdir}/profile.d
63 cat << EOF > %{buildroot}%{_sysconfdir}/profile.d/AGL-%{name}.sh
64 #----------  AGL %%{name} options Start ---------"
65 # Object: AGL cmake option for  binder/bindings
66 export LD_LIBRARY_PATH=%{_libdir}:\${LD_LIBRARY_PATH}
67 export LIBRARY_PATH=%{_libdir}:\${LIBRARY_PATH}
68 export PKG_CONFIG_PATH=%{_libdir}/pkgconfig:\${PKG_CONFIG_PATH}
69 export PATH=%{_bindir}:\$PATH
70 #----------  AGL options End ---------
71 EOF
72
73 %post
74
75 %postun
76
77 %files
78 %defattr(-,root,root)
79 %dir %{_bindir}
80 %{_bindir}/afb-client-demo
81 %{_bindir}/afb-daemon
82 %{_bindir}/afb-genskel
83 %{_bindir}/afb-exprefs
84 %{_bindir}/afb-json2c
85
86 %dir %{_libdir}
87 %dir %{_libdir}/afb
88 %{_libdir}/libafbwsc.so.1
89 %{_libdir}/libafbwsc.so.1.1
90
91 #app-framework-binder demo
92 %{_libdir}/afb/*.so
93 %config(noreplace) %{_sysconfdir}/profile.d/AGL-%{name}.sh
94
95 #app-framework-binder monitoring
96 %dir %{_libdir}/afb/monitoring
97 %{_libdir}/afb/monitoring/*
98
99 %files devel
100 %defattr(-,root,root)
101 %dir %{_prefix}
102 %{_libdir}/libafbwsc.so
103 %dir %{_includedir}
104 %dir %{_includedir}/afb
105 %{_includedir}/afb/*
106 %dir %{_libdir}/pkgconfig
107 %{_libdir}/pkgconfig/*.pc
108
109 %changelog
110 * Wed Sep 27 2017 Dominig
111 - move to git repo
112 * Tue Aug 01 2017 Ronan
113 - initial creation