meta-app-framework: make applaunchd polkit dependency explicit 20/29020/2
authorScott Murray <scott.murray@konsulko.com>
Thu, 15 Jun 2023 22:03:10 +0000 (18:03 -0400)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 16 Jun 2023 16:10:54 +0000 (16:10 +0000)
Since there seems to be no inherent dependency in the shipped systemd
default or polkit unit files with respect to polkit availability with
respect to network.target, we do seem to need to make applaunchd's
dependency on polkit explicit to guarantee systemd DBus API access
works.  As well, it seems worthwhile to enforce the systemd and polkit
DISTRO_FEATURES being present if someone attempts to build applaunchd,
so update the recipe to do so.

Bug-AGL: SPEC-4840

Change-Id: I1cc998ac7c6234de0bb857d4c4fda00d847e00bf
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29020
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-app-framework/recipes-core/applaunchd/applaunchd/applaunchd.service
meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb

index a5a2df5..b4c2b0a 100644 (file)
@@ -1,6 +1,6 @@
 [Unit]
-Wants=network.target
-After=network.target
+Wants=network.target polkit.service
+After=network.target polkit.service
 
 [Service]
 User=applaunchd
index 767c8bc..38d89b2 100644 (file)
@@ -29,7 +29,9 @@ SRCREV = "7a3e870a8349d43a4838604db2c28140c2f76c9f"
 
 S = "${WORKDIR}/git"
 
-inherit meson pkgconfig systemd useradd
+inherit meson pkgconfig systemd useradd features_check
+
+REQUIRED_DISTRO_FEATURES = "systemd polkit"
 
 USERADD_PACKAGES = "${PN}"
 USERADDEXTENSION = "useradd-staticids"