meta-rcar-gen3: fix rc.pvr weston dependency 12/25012/3
authorScott Murray <scott.murray@konsulko.com>
Mon, 13 Jul 2020 21:45:11 +0000 (17:45 -0400)
committerScott Murray <scott.murray@konsulko.com>
Tue, 14 Jul 2020 14:32:29 +0000 (14:32 +0000)
Add a do_install_append to fix rc.pvr systemd unit weston dependency,
it needs to be weston@.service to work with YP dunfell / 3.1.

Bug-AGL: SPEC-3380, SPEC-3443

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I5f2a6d858c09812ab06e7a1a572fdd96801a8269
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25012
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-by: Stéphane Desneux <stephane.desneux@iot.bzh>
meta-agl-bsp/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bbappend

index b902fc9..e50822f 100644 (file)
@@ -1 +1,8 @@
 require checksum_control.inc
+
+do_install_append() {
+    # Fix weston dependency, needs to be weston@.service
+    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} ; then
+        sed -i 's/^RequiredBy=weston.service$/RequiredBy=weston@.service/' ${D}${systemd_system_unitdir}/rc.pvr.service
+    fi
+}