meta-agl-core-test: Fix freetype-demos build
authorScott Murray <scott.murray@konsulko.com>
Mon, 1 Mar 2021 21:51:26 +0000 (16:51 -0500)
committerScott Murray <scott.murray@konsulko.com>
Tue, 29 Mar 2022 19:24:56 +0000 (15:24 -0400)
Update freetype bbappend and patches for building freetype-demos
with freetype 2.11 in poky master.

Bug-AGL: SPEC-3819

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I393cec758934786cfa1d9d261b7e069b4d7514b5

meta-agl-core-test/recipes-test/freetype/files/0001-Makefile-dont-build-gfx-demos.patch
meta-agl-core-test/recipes-test/freetype/files/0001-ft2demos-Makefile-Do-not-hardcode-libtool-path.patch
meta-agl-core-test/recipes-test/freetype/freetype_2.%.bbappend

index 4d0d09a..bd9b4c0 100644 (file)
@@ -1,17 +1,16 @@
-diff -ur ft2demos-2.9.1.orig/Makefile ft2demos-2.9.1/Makefile
---- ft2demos-2.9.1.orig/Makefile       2018-04-22 05:41:50.000000000 -0400
-+++ ft2demos-2.9.1/Makefile    2019-02-18 23:28:59.794678736 -0500
-@@ -163,7 +163,8 @@
-   ifeq ($(PLATFORM),unix)
-     CC        = $(CCraw)
--    LINK_CMD  = $(subst /,$(SEP),$(OBJ_BUILD)/libtool) \
-+      LIBTOOL   = $(OBJ_BUILD)/libtool
-+    LINK_CMD  = $(subst /,$(SEP),$(LIBTOOL)) \
-                 --mode=link $(CC) \
-                 $(subst /,$(COMPILER_SEP),$(LDFLAGS))
-     LINK_LIBS = $(subst /,$(COMPILER_SEP),$(FTLIB) $(EFENCE)) $(LIB_CLOCK_GETTIME)
-@@ -289,12 +290,12 @@
+Do not build graphics tests
+
+Upstream-Status: Inappropriate [disable feature]
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+---
+ Makefile | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 8bb8666..95e5e45 100644
+--- a/Makefile
++++ b/Makefile
+@@ -297,13 +297,13 @@ else
            ttdebug
  
    # Comment out the next line if you don't have a graphics subsystem.
@@ -19,14 +18,16 @@ diff -ur ft2demos-2.9.1.orig/Makefile ft2demos-2.9.1/Makefile
 -          ftgamma  \
 -          ftgrid   \
 -          ftmulti  \
+-          ftsdf    \
 -          ftstring \
 -          ftview
-+  # EXES += ftdiff   \
-+  #         ftgamma  \
-+  #         ftgrid   \
-+  #         ftmulti  \
-+  #         ftstring \
-+  #         ftview
++  #EXES += ftdiff   \
++  #        ftgamma  \
++  #        ftgrid   \
++  #        ftmulti  \
++  #        ftsdf    \
++  #        ftstring \
++  #        ftview
  
    # ftvalid requires ftgxval.c and ftotval.c
    #
index 7803ad7..879b805 100644 (file)
@@ -8,23 +8,24 @@ Content-Transfer-Encoding: 8bit
 
 It is already known and imported through config.mk.
 
+Upstream-Status: Inappropriate [embedded specific]
 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
+[Updated for freetype 2.10.4]
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
 ---
- Makefile | -
- 1 file changed, 1 deletion(-)
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
 
 diff --git a/Makefile b/Makefile
-index a5d34bd..254aad4 100644
+index 851c4f7..c537983 100644
 --- a/Makefile
 +++ b/Makefile
-@@ -153,7 +153,6 @@ else
+@@ -165,7 +165,7 @@ else
  
    ifeq ($(PLATFORM),unix)
-     CC        = $(CCraw)
--      LIBTOOL   = $(OBJ_BUILD)/libtool
-     LINK_CMD  = $(subst /,$(SEP),$(LIBTOOL)) \
-                 --mode=link $(CC) \
-                 $(subst /,$(COMPILER_SEP),$(LDFLAGS))
--- 
-2.1.4
-
+     override CC = $(CCraw)
+-    LINK_CMD    = $(subst /,$(SEP),$(OBJ_BUILD)/libtool) \
++    LINK_CMD  = $(subst /,$(SEP),$(LIBTOOL)) \
+                   --mode=link $(CC) \
+                   $(subst /,$(COMPILER_SEP),$(LDFLAGS))
+     LINK_LIBS   = $(subst /,$(COMPILER_SEP),$(FTLIB) $(EFENCE)) $(LIB_CLOCK_GETTIME)
index 8fc56fa..b6c14c4 100644 (file)
@@ -1,27 +1,26 @@
 FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
 
-SRC_URI =+ "${SOURCEFORGE_MIRROR}/freetype/freetype-demos/${PV}/ft2demos-${PV}.tar.gz;name=ft2demos \
-           file://0001-Makefile-dont-build-gfx-demos.patch;patchdir=../ft2demos-${PV} \
-           file://0001-ft2demos-Makefile-Do-not-hardcode-libtool-path.patch;patchdir=../ft2demos-${PV} \
-          "
-SRC_URI[ft2demos.md5sum] = "c376adf4782bac9b9ac8e427884752d2"
-SRC_URI[ft2demos.sha256sum] = "5e9e94a2db9d1a945293a1644a502f6664a2173a454d4a55b19695e2e2f4a0bc"
+SRC_URI += "${SOURCEFORGE_MIRROR}/freetype/freetype-demos/${PV}/ft2demos-${PV}.tar.gz;name=ft2demos \
+            file://0001-Makefile-dont-build-gfx-demos.patch;patchdir=../ft2demos-${PV} \
+           "
+SRC_URI[ft2demos.sha256sum] = "95939c04b72872f2c6053a436b385c614530322bda7a7966efbc4d281f710af6"
 
-PACKAGES =+ "${PN}-demos"
-
-B = "${S}"
+# Enable pixmap/libpng support to allow color emojis
+PACKAGECONFIG:append = " pixmap"
 
 do_compile:append () {
-    oe_runmake -C ${WORKDIR}/ft2demos-${PV} TOP_DIR=${WORKDIR}/${BPN}-${PV}/
+    oe_runmake -C ${B} FT2DEMOS=1 TOP_DIR_2=${WORKDIR}/ft2demos-${PV}
 }
 
 do_install:append () {
-    install -d -m 0755 ${D}/${bindir}
+    install -d -m 0755 ${D}${bindir}
     for x in ftbench ftdump ftlint ftvalid ttdebug; do
-        install -m 0755 ${WORKDIR}/ft2demos-${PV}/bin/.libs/$x ${D}/${bindir}
+        install -m 0755 ${WORKDIR}/ft2demos-${PV}/bin/.libs/$x ${D}${bindir}
     done
 }
 
+PACKAGE_BEFORE_PN = "${PN}-demos"
+
 FILES:${PN}-demos = "\
     ${bindir}/ftbench \
     ${bindir}/ftdump \
@@ -29,6 +28,3 @@ FILES:${PN}-demos = "\
     ${bindir}/ftvalid \
     ${bindir}/ttdebug \
 "
-
-# enable pixmap/libpng support to allow color emojis
-PACKAGECONFIG:append = " pixmap"