weston: Launch even without input devices 71/6871/2
authorLeon Anavi <leon.anavi@konsulko.com>
Mon, 24 Oct 2016 12:24:57 +0000 (15:24 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 24 Oct 2016 15:03:47 +0000 (15:03 +0000)
Launch Weston even if there are no input devices
such a keyboard or a mouse.

Bug-AGL: SPEC-297

Change-Id: I3187b310b1024ef77d4696a06b325bface5de2b3
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch [new file with mode: 0644]
meta-agl/recipes-graphics/wayland/weston_1.9.0.bb

diff --git a/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch b/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch
new file mode 100644 (file)
index 0000000..0d7b9ee
--- /dev/null
@@ -0,0 +1,28 @@
+From d46538cde290f2638d3631a8789f659b433c2d2a Mon Sep 17 00:00:00 2001
+From: Leon Anavi <leon.anavi@konsulko.com>
+Date: Mon, 24 Oct 2016 14:54:02 +0300
+Subject: [PATCH] compositor-drm.c: Launch without input devices
+
+Launch Weston 1.9 even if input devices (such as
+a keyboard or a mouse) are not present.
+
+Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
+---
+ src/compositor-drm.c | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/compositor-drm.c b/src/compositor-drm.c
+index 6777bf8..ab493ad 100644
+--- a/src/compositor-drm.c
++++ b/src/compositor-drm.c
+@@ -3149,7 +3149,6 @@ drm_backend_create(struct weston_compositor *compositor,
+       if (udev_input_init(&b->input,
+                           compositor, b->udev, param->seat_id) < 0) {
+               weston_log("failed to create input devices\n");
+-              goto err_sprite;
+       }
+       if (create_outputs(b, param->connector, drm_device) < 0) {
+-- 
+2.7.4
+
index 5d51992..bee457a 100644 (file)
@@ -11,6 +11,7 @@ SRC_URI = "http://wayland.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
            file://make-lcms-explicitly-configurable.patch \
            file://make-libwebp-explicitly-configurable.patch \
            file://0001-make-error-portable.patch \
+           file://0001-compositor-drm.c-Launch-without-input-devices.patch \
 "
 SRC_URI[md5sum] = "66bbba12f546570b4d97f676bc79a28e"
 SRC_URI[sha256sum] = "9c1b03f3184fa0b0dfdf67e215048085156e1a2ca344af6613fed36794ac48cf"