meta-agl-bsp: make meta-rcar-gen3 BBMASKs more specific 18/28418/3
authorScott Murray <scott.murray@konsulko.com>
Tue, 17 Jan 2023 17:47:59 +0000 (12:47 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sun, 29 Jan 2023 14:30:03 +0000 (14:30 +0000)
Update the BBMASK definitions for the rcar3 platforms in meta-agl-bsp
to include the meta-renesas/ component of the path so that they will
not mask out any of our files under meta-agl-bsp/meta-rcar-gen3.

Bug-AGL: SPEC-4618

Change-Id: I6434f54bb50784c0673b54648165e0c5118f0c7e
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
(cherry picked from commit b5001a4a5abbe8e7944446025dd63be725c491e4)
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28418
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
meta-agl-bsp/conf/include/agl_rcar.inc

index c62b9d0..fb67fd9 100644 (file)
@@ -44,10 +44,10 @@ PSEUDO_IGNORE_PATHS:append:pn-kernel-module-vspm = ",${KERNELSRC}"
 
 # Mask out base-files and systemd bbappends to avoid changing systemd-tmpfiles
 # behavior, see SPEC-4256 for a more involved explanation.
-BBMASK += "meta-rcar-gen3/recipes-core/base-files/ meta-rcar-gen3/recipes-core/systemd/"
+BBMASK += "meta-renesas/meta-rcar-gen3/recipes-core/base-files/ meta-renesas/meta-rcar-gen3/recipes-core/systemd/"
 
 # Mask out cogl bbappend to avoid meta-gnome dependency
-BBMASK += "meta-rcar-gen3/recipes-graphics/cogl/cogl-1.0_1.%.bbappend"
+BBMASK += "meta-renesas/meta-rcar-gen3/recipes-graphics/cogl/cogl-1.0_1.%.bbappend"
 
 # Provide default value that avoids errors from a new packaging QA
 # check with respect to packagegroups depending on versioned library
index da0819d..e1169c2 100644 (file)
@@ -42,7 +42,7 @@ DISTRO_FEATURES:append:rcar-gen3 = " h264dec_lib h264enc_lib aaclcdec_lib aaclcd
 # getting weston started.  There is no clear rationale expressed in the
 # meta-renesas-rcar-gen3 commit history for the extra dependencies, and
 # testing shows no issues on H3ULCB when not having them.
-BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend"
+BBMASK += "meta-renesas/meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend"
 
 # Add graphics and decoder drivers to packagegroup-machine-base
 # recommendation.