Update to YP dunfell 3.1.5 42/26042/2
authorScott Murray <scott.murray@konsulko.com>
Wed, 10 Feb 2021 18:58:29 +0000 (13:58 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 17 Feb 2021 18:24:55 +0000 (18:24 +0000)
Changes include:
- Backport gstreamer 1.16.2 vs 1.16.3 workaround for rcar3
  (originally for SPEC-3706 in master, now updated per SPEC-3803).
- Add 1.16.% wildcard version of meta-rcar-gen3-adas Kingfisher
  support layer gstreamer1.0-plugins-bad bbappend.  The issue is the
  same as with the main meta-rcar-gen3 BSP layer bbappends mentioned
  above, but this particular bbappend has been disabled in the newer
  BSP in master/koi, so they did not need a fix.
- Add override of PREFERRED_VERSION_libdrm for rcar3 to quiet
  warnings about 2.4.100 not being available, which are caused by
  dunfell 3.1.5 bringing an update to 2.4.101.
- Pin Raspberry Pi kernel version to 4.19.  meta-raspberrypi
  upstream has switched their default kernel to 5.4 on their
  dunfell branch, but that significant of a change is not desirable
  in a AGL point release.
- Remove now upstreamed systemd patch.

Bug-AGL: SPEC-3793, SPEC-3803

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: Ia678b8f56f35026a62a9f6ab40f9727b10756ad6
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26042
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
18 files changed:
meta-agl-bsp/conf/include/agl_h3ulcb-nogfx.inc
meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc
meta-agl-bsp/conf/include/agl_raspberrypi3.inc
meta-agl-bsp/conf/include/agl_raspberrypi4.inc
meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
meta-agl-bsp/conf/include/agl_rcar.inc
meta-agl-bsp/meta-rcar-gen3-adas/cogent-symlinks/recipes-multimedia/gstreamer [deleted symlink]
meta-agl-bsp/meta-rcar-gen3-adas/cogent-symlinks/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend [new symlink]
meta-agl-bsp/meta-rcar-gen3-adas/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-install-wayland.h-header.patch [new file with mode: 0644]
meta-agl-bsp/meta-rcar-gen3-adas/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-pkgconfig-libgstwayland.patch [new file with mode: 0644]
meta-agl-bsp/meta-rcar-gen3-adas/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0003-gstkmssink-add-rcar-du-to-driver-list.patch [new file with mode: 0644]
meta-agl-bsp/meta-rcar-gen3-adas/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend [new file with mode: 0644]
meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx/gstomx.conf [new file with mode: 0644]
meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16.3.bbappend [new file with mode: 0644]
meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.3.bbappend [new file with mode: 0644]
meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.3.bbappend [new file with mode: 0644]
meta-agl-profile-core/recipes-core/systemd/systemd/0001-fix-udevd-seclabel-parsing.patch [deleted file]
meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend

index 25755d2..70bc68b 100644 (file)
@@ -8,3 +8,6 @@ DTB_SUFFIX = "r8a7795-h3ulcb"
 BBMASK += "gles-user-module|kernel-module-gles|wayland-kms|libgbm"
 # Mask MMP recipes
 BBMASK += "kernel-module-uvcs-drv|omx-user-module"
+
+# Workaround for SPEC-3706 - versioned bbappends and upstream moved on to 1.16.3
+BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-.*1.16.2\.bbappend"
index 5092c4b..28360fc 100644 (file)
@@ -12,3 +12,5 @@ BBMASK += "kernel-module-uvcs-drv|omx-user-module"
 DISTRO_FEATURES_append = "${@bb.utils.contains('AGL_XEN_WANTED', '1', ' xen', '', d)}"
 IMAGE_INSTALL_append = "${@bb.utils.contains('AGL_XEN_WANTED', '1', ' xen-base xen-mkimage', '', d)}"
 
+# Workaround for SPEC-3706 - versioned bbappends and upstream moved on to 1.16.3
+BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-.*1.16.2\.bbappend"
index a4989b7..c0538dd 100644 (file)
@@ -4,6 +4,9 @@ GPU_MEM = "256"
 # Add CMA to the kernel arguments for SOTA
 OSTREE_KERNEL_ARGS_sota_append = " cma=256M"
 
+# Use 4.19 kernel for jellyfish
+PREFERRED_VERSION_linux-raspberrypi = "4.19.%"
+
 #MULTI_PROVIDER_WHITELIST += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
 
 # use u-boot always
index ae302aa..15ed8c8 100644 (file)
@@ -4,6 +4,9 @@ GPU_MEM = "256"
 # Add CMA to the kernel arguments for SOTA
 OSTREE_KERNEL_ARGS_sota_append = " cma=256M"
 
+# Use 4.19 kernel for jellyfish
+PREFERRED_VERSION_linux-raspberrypi = "4.19.%"
+
 # use u-boot always
 RPI_USE_U_BOOT = "1"
 
index 3ffded7..3c45fdf 100644 (file)
@@ -10,4 +10,7 @@ RENESAS_DATADIR = "/usr"
 
 IMAGE_INSTALL_append_rcar-gen3 = " \
     kernel-devicetree \
-"
\ No newline at end of file
+"
+
+# Quiet warnings about unavailable 2.4.100 version due to upstream update
+PREFERRED_VERSION_libdrm_rcar-gen3 = "2.4.101"
index cfdff9d..c14d5d1 100644 (file)
@@ -40,6 +40,9 @@ DISTRO_FEATURES_append = " h264dec_lib h264enc_lib aaclcdec_lib aaclcdec_mdw"
 # testing shows no issues on H3ULCB when not having them.
 BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend"
 
+# Workaround for SPEC-3706 - versioned bbappends and upstream moved on to 1.16.3
+BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-.*1.16.2\.bbappend"
+
 IMAGE_INSTALL_append_rcar-gen3 = " \
     kernel-module-pvrsrvkm \
     kernel-module-vsp2 \
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/cogent-symlinks/recipes-multimedia/gstreamer b/meta-agl-bsp/meta-rcar-gen3-adas/cogent-symlinks/recipes-multimedia/gstreamer
deleted file mode 120000 (symlink)
index ef3ed76..0000000
+++ /dev/null
@@ -1 +0,0 @@
-../../../../../bsp/meta-rcar/meta-rcar-gen3-adas/recipes-multimedia/gstreamer/
\ No newline at end of file
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/cogent-symlinks/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend b/meta-agl-bsp/meta-rcar-gen3-adas/cogent-symlinks/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend
new file mode 120000 (symlink)
index 0000000..2175b25
--- /dev/null
@@ -0,0 +1 @@
+../../../../../../bsp/meta-rcar/meta-rcar-gen3-adas/recipes-multimedia/gstreamer/gstreamer1.0-omx_%.bbappend
\ No newline at end of file
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-install-wayland.h-header.patch b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-install-wayland.h-header.patch
new file mode 100644 (file)
index 0000000..d98ca26
--- /dev/null
@@ -0,0 +1,33 @@
+From 688a7bfe44a3ca9029fccdb1f7bfdd405927dade Mon Sep 17 00:00:00 2001
+From: Grigory Kletsko <grigory.kletsko@cogentembedded.com>
+Date: Thu, 5 May 2016 15:55:55 +0300
+Subject: [PATCH] install wayland.h header
+
+---
+ gst-libs/gst/wayland/Makefile.am | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/gst-libs/gst/wayland/Makefile.am b/gst-libs/gst/wayland/Makefile.am
+index a9f3f7b..7281a6e 100644
+--- a/gst-libs/gst/wayland/Makefile.am
++++ b/gst-libs/gst/wayland/Makefile.am
+@@ -5,6 +5,8 @@ libgstwayland_@GST_API_VERSION@_la_SOURCES = wayland.c
+ libgstwayland_@GST_API_VERSION@includedir = \
+       $(includedir)/gstreamer-@GST_API_VERSION@/gst/wayland
++libgstwayland_@GST_API_VERSION@include_HEADERS = wayland.h
++
+ libgstwayland_@GST_API_VERSION@_la_CFLAGS = \
+       $(GST_PLUGINS_BAD_CFLAGS) \
+       $(GST_PLUGINS_BASE_CFLAGS) \
+@@ -22,7 +24,3 @@ libgstwayland_@GST_API_VERSION@_la_LDFLAGS = \
+       $(GST_LIB_LDFLAGS) \
+       $(GST_ALL_LDFLAGS) \
+       $(GST_LT_LDFLAGS)
+-
+-noinst_HEADERS = \
+-      wayland.h
+-
+-- 
+2.5.0
+
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-pkgconfig-libgstwayland.patch b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-pkgconfig-libgstwayland.patch
new file mode 100644 (file)
index 0000000..f677b43
--- /dev/null
@@ -0,0 +1,32 @@
+From 96044f1d3773ba2783e3956729cd9c85b04733da Mon Sep 17 00:00:00 2001
+From: Grigory Kletsko <grigory.kletsko@cogentembedded.com>
+Date: Thu, 12 May 2016 21:24:38 +0300
+Subject: [PATCH] fix
+
+---
+ pkgconfig/Makefile.am | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/pkgconfig/Makefile.am b/pkgconfig/Makefile.am
+index 8e74a8e..f641285 100644
+--- a/pkgconfig/Makefile.am
++++ b/pkgconfig/Makefile.am
+@@ -1,6 +1,7 @@
+ ### all of the standard pc files we need to generate
+ pcverfiles =  \
++      gstreamer-wayland-@GST_API_VERSION@.pc \
+       gstreamer-plugins-bad-@GST_API_VERSION@.pc \
+       gstreamer-codecparsers-@GST_API_VERSION@.pc \
+       gstreamer-insertbin-@GST_API_VERSION@.pc \
+@@ -11,6 +12,7 @@ pcverfiles =  \
+       gstreamer-bad-audio-@GST_API_VERSION@.pc
+ pcverfiles_uninstalled = \
++      gstreamer-wayland-@GST_API_VERSION@-uninstalled.pc \
+       gstreamer-plugins-bad-@GST_API_VERSION@-uninstalled.pc \
+       gstreamer-codecparsers-@GST_API_VERSION@-uninstalled.pc \
+       gstreamer-insertbin-@GST_API_VERSION@-uninstalled.pc \
+-- 
+2.5.0
+
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0003-gstkmssink-add-rcar-du-to-driver-list.patch b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0003-gstkmssink-add-rcar-du-to-driver-list.patch
new file mode 100644 (file)
index 0000000..6b421ac
--- /dev/null
@@ -0,0 +1,25 @@
+From 300a679bd033d9b3fcf6873b1cd0385f0e0435ae Mon Sep 17 00:00:00 2001
+From: Sergey Nazaryev <sergey.nazaryev@cogentembedded.com>
+Date: Tue, 26 Feb 2019 17:55:54 +0300
+Subject: [PATCH] gstkmssink: add rcar-du to driver list
+
+---
+ sys/kms/gstkmssink.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/sys/kms/gstkmssink.c b/sys/kms/gstkmssink.c
+index cdecbf6..0b11233 100644
+--- a/sys/kms/gstkmssink.c
++++ b/sys/kms/gstkmssink.c
+@@ -177,7 +177,7 @@ kms_open (gchar ** driver)
+ {
+   static const char *drivers[] = { "i915", "radeon", "nouveau", "vmwgfx",
+     "exynos", "amdgpu", "imx-drm", "rockchip", "atmel-hlcdc", "msm",
+-    "xlnx", "vc4", "meson", "sun4i-drm", "mxsfb-drm",
++    "xlnx", "vc4", "meson", "sun4i-drm", "mxsfb-drm", "rcar-du",
+     "xilinx_drm",               /* DEPRECATED. Replaced by xlnx */
+   };
+   int i, fd = -1;
+-- 
+2.7.4
+
diff --git a/meta-agl-bsp/meta-rcar-gen3-adas/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend b/meta-agl-bsp/meta-rcar-gen3-adas/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend
new file mode 100644 (file)
index 0000000..3d91030
--- /dev/null
@@ -0,0 +1,13 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+
+SRC_URI_append = " \
+    file://0001-install-wayland.h-header.patch \
+    file://0002-pkgconfig-libgstwayland.patch \
+    file://0003-gstkmssink-add-rcar-du-to-driver-list.patch \
+"
+
+PACKAGECONFIG_append = " kms"
+
+PACKAGECONFIG_remove = '${@ "vulkan" if not ('opengl' in '${DISTRO_FEATURES}') else ""}'
+DEPENDS_remove = '${@ "weston" if not ('wayland' in '${DISTRO_FEATURES}') else ""}'
+RDEPENDS_gstreamer1.0-plugins-bad_remove = '${@bb.utils.contains("DISTRO_FEATURES", "wayland opengl", "", "libwayland-egl", d)}'
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx/gstomx.conf b/meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx/gstomx.conf
new file mode 100644 (file)
index 0000000..5fca3ee
--- /dev/null
@@ -0,0 +1,131 @@
+[omxh264dec]
+type-name=GstOMXH264Dec
+core-name=@RENESAS_DATADIR@/lib/libomxr_core.so
+component-name=OMX.RENESAS.VIDEO.DECODER.H264
+rank=512
+in-port-index=0
+out-port-index=1
+hacks=no-disable-outport;default-pix-aspect-ratio;no-component-reconfigure
+sink-template-caps=video/x-h264,alignment=(string)au,stream-format=(string)byte-stream,width=(int)[1, MAX],height=(int)[1, MAX]
+src-template-caps=video/x-raw,format=(string){NV12,I420},width=(int)[1, MAX],height=(int)[1, MAX]
+
+[omxaaclcdec]
+type-name=GstOMXAACDec
+core-name=@RENESAS_DATADIR@/lib/libomxr_core.so
+component-name=OMX.RENESAS.AUDIO.DECODER.AACLC
+rank=256
+in-port-index=0
+out-port-index=1
+hacks=no-disable-outport
+sink-template-caps=audio/mpeg,mpegversion=(int){2,4},stream-format=(string){raw,adts},rate=(int)[8000,96000],channels=(int)[1,2],framed=(boolean)true
+src-template-caps=audio/x-raw,rate=(int)[8000,96000],channels=(int)[1,2],format=(string)S16LE
+
+[omxmpeg4videodec]
+type-name=GstOMXMPEG4VideoDec
+core-name=@RENESAS_DATADIR@/lib/libomxr_core.so
+component-name=OMX.RENESAS.VIDEO.DECODER.MPEG4
+rank=256
+in-port-index=0
+out-port-index=1
+hacks=no-disable-outport;default-pix-aspect-ratio;no-component-reconfigure
+sink-template-caps=video/mpeg,mpegversion=(int)4,systemstream=(boolean)false,parsed=(boolean)true,width=(int)[1, MAX],height=(int)[1, MAX]
+src-template-caps=video/x-raw,format=(string){NV12,I420},width=(int)[1, MAX],height=(int)[1, MAX]
+
+[omxvc1dec]
+type-name=GstOMXWMVDec
+core-name=@RENESAS_DATADIR@/lib/libomxr_core.so
+component-name=OMX.RENESAS.VIDEO.DECODER.VC1
+rank=256
+in-port-index=0
+out-port-index=1
+hacks=no-disable-outport;default-pix-aspect-ratio;no-component-reconfigure
+sink-template-caps=video/x-wmv,wmvversion=(int)3,width=(int)[1, MAX],height=(int)[1, MAX]
+src-template-caps=video/x-raw,format=(string){NV12,I420},width=(int)[1, MAX],height=(int)[1, MAX]
+
+[omxh265dec]
+type-name=GstOMXH265Dec
+core-name=@RENESAS_DATADIR@/lib/libomxr_core.so
+component-name=OMX.RENESAS.VIDEO.DECODER.H265
+rank=256
+in-port-index=0
+out-port-index=1
+hacks=no-disable-outport;default-pix-aspect-ratio;no-component-reconfigure
+sink-template-caps=video/x-h265,alignment=(string)au,stream-format=(string)byte-stream,width=(int)[1, MAX],height=(int)[1, MAX]
+src-template-caps=video/x-raw,format=(string){NV12,I420},width=(int)[1, MAX],height=(int)[1, MAX]
+
+[omxaacdec]
+type-name=GstOMXAACDec
+core-name=@RENESAS_DATADIR@/lib/libomxr_core.so
+component-name=OMX.RENESAS.AUDIO.DECODER.AAC
+rank=256
+in-port-index=0
+out-port-index=1
+hacks=no-disable-outport
+sink-template-caps=audio/mpeg,mpegversion=(int){2,4},stream-format=(string){raw,adts},rate=(int)[8000,48000],channels=(int)[1,6],framed=(boolean)true
+src-template-caps=audio/x-raw,rate=(int)[8000,48000],channels=(int){1,2,6},format=(string)S16LE
+
+[omxmp3dec]
+type-name=GstOMXMP3Dec
+core-name=@RENESAS_DATADIR@/lib/libomxr_core.so
+component-name=OMX.RENESAS.AUDIO.DECODER.MP3
+rank=256
+in-port-index=0
+out-port-index=1
+hacks=no-disable-outport
+sink-template-caps=audio/mpeg,mpegversion=(int)1,layer=(int)[1,3],mpegaudioversion=(int)[1,3],rate=(int)[8000,48000],channels=(int)[1,2],parsed=(boolean) true
+src-template-caps=audio/x-raw,rate=(int)[8000,48000],channels=(int){1,2},format=(string)S16LE
+
+[omxwmadec]
+type-name=GstOMXWMADec
+core-name=@RENESAS_DATADIR@/lib/libomxr_core.so
+component-name=OMX.RENESAS.AUDIO.DECODER.WMA
+rank=256
+in-port-index=0
+out-port-index=1
+hacks=no-disable-outport;skip-handle-codec-data
+sink-template-caps=audio/x-wma,wmaversion=(int)2,rate=(int)[8000,48000],channels=(int){1,2},block_align=(int)[0,2147483647],bitrate=(int)[0,2147483647]
+src-template-caps=audio/x-raw,rate=(int)[8000,48000],channels=(int){1,2},format=(string)S16LE
+
+[omxh264enc]
+type-name=GstOMXH264Enc
+core-name=@RENESAS_DATADIR@/lib/libomxr_core.so
+component-name=OMX.RENESAS.VIDEO.ENCODER.H264
+rank=256
+in-port-index=0
+out-port-index=1
+hacks=no-disable-outport;renesas-encmc-stride-align
+sink-template-caps=video/x-raw,format=(string){NV12,I420},width=(int)[80,3840],height=(int)[80,2160]
+src-template-caps=video/x-h264,stream-format=(string)byte-stream,width=(int)[80,3840],height=(int)[80,2160]
+
+[omxvp8dec]
+type-name=GstOMXVP8Dec
+core-name=@RENESAS_DATADIR@/lib/libomxr_core.so
+component-name=OMX.RENESAS.VIDEO.DECODER.VP8
+rank=256
+in-port-index=0
+out-port-index=1
+hacks=no-disable-outport;default-pix-aspect-ratio;no-component-reconfigure
+sink-template-caps=video/x-vp8,width=(int)[1, MAX],height=(int)[1, MAX]
+src-template-caps=video/x-raw,format=(string){NV12,I420},width=(int)[1, MAX],height=(int)[1, MAX]
+
+[omxvp8enc]
+type-name=GstOMXVP8Enc
+core-name=@RENESAS_DATADIR@/lib/libomxr_core.so
+component-name=OMX.RENESAS.VIDEO.ENCODER.VP8
+rank=256
+in-port-index=0
+out-port-index=1
+hacks=no-disable-outport;renesas-encmc-stride-align
+sink-template-caps=video/x-raw,format=(string){NV12,I420},width=(int)[80,1920],height=(int)[80,1080]
+src-template-caps=video/x-vp8,width=(int)[80,1920],height=(int)[80,1080]
+
+[omxvp9dec]
+type-name=GstOMXVP9Dec
+core-name=@RENESAS_DATADIR@/lib/libomxr_core.so
+component-name=OMX.RENESAS.VIDEO.DECODER.VP9
+rank=256
+in-port-index=0
+out-port-index=1
+hacks=no-disable-outport;default-pix-aspect-ratio;no-component-reconfigure
+sink-template-caps=video/x-vp9,width=(int)[1, MAX],height=(int)[1, MAX]
+src-template-caps=video/x-raw,format=(string){NV12,I420},width=(int)[1, MAX],height=(int)[1, MAX]
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16.3.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16.3.bbappend
new file mode 100644 (file)
index 0000000..3f87a75
--- /dev/null
@@ -0,0 +1,33 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
+
+SRC_URI_remove = "http://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${PV}.tar.xz"
+SRC_URI_append = " \
+    gitsm://github.com/renesas-rcar/gst-omx.git;branch=RCAR-GEN3/1.16.3 \
+    file://gstomx.conf \
+"
+
+require include/rcar-gen3-path-common.inc
+
+DEPENDS += "omx-user-module mmngrbuf-user-module"
+
+SRCREV = "d9748c48c75e8c108af0300d9f452282d266ebd5"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
+    file://omx/gstomx.h;beginline=1;endline=22;md5=e2c6664eda77dc22095adbed9cb6c6e4 \
+"
+
+S = "${WORKDIR}/git"
+
+GSTREAMER_1_0_OMX_TARGET = "rcar"
+GSTREAMER_1_0_OMX_CORE_NAME = "${libdir}/libomxr_core.so"
+EXTRA_OEMESON_append = " -Dheader_path=${STAGING_DIR_TARGET}/usr/local/include"
+
+do_configure_prepend() {
+    cd ${S}
+    install -m 0644 ${WORKDIR}/gstomx.conf ${S}/config/rcar/
+    sed -i 's,@RENESAS_DATADIR@,${RENESAS_DATADIR},g' ${S}/config/rcar/gstomx.conf
+    cd ${B}
+}
+
+RDEPENDS_${PN}_append = " omx-user-module"
+RDEPENDS_${PN}_remove = "libomxil"
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.3.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.3.bbappend
new file mode 100644 (file)
index 0000000..119fb9a
--- /dev/null
@@ -0,0 +1,8 @@
+SRC_URI_remove = "http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-${PV}.tar.xz"
+SRC_URI_append = " gitsm://github.com/renesas-rcar/gst-plugins-bad.git;branch=RCAR-GEN3/1.16.3"
+
+SRCREV = "3ef17d3c57e12f9d7536e464656b871a8949fa5b"
+
+DEPENDS += "weston"
+
+S = "${WORKDIR}/git"
diff --git a/meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.3.bbappend b/meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.3.bbappend
new file mode 100644 (file)
index 0000000..2007687
--- /dev/null
@@ -0,0 +1,13 @@
+SRC_URI_remove = "http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz"
+SRC_URI_append = " gitsm://github.com/renesas-rcar/gst-plugins-good.git;branch=RCAR-GEN3/1.16.3"
+
+SRCREV = "ca2036d2b09a434adc52aa02890c1503bf7100bf"
+
+DEPENDS += "mmngrbuf-user-module"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMESON_append = " \
+    -Dcont-frame-capture=true \
+    -Dignore-fps-of-video-standard=true \
+"
diff --git a/meta-agl-profile-core/recipes-core/systemd/systemd/0001-fix-udevd-seclabel-parsing.patch b/meta-agl-profile-core/recipes-core/systemd/systemd/0001-fix-udevd-seclabel-parsing.patch
deleted file mode 100644 (file)
index 29165b5..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-Fix udevd SECLABEL token parsing
-
-The udevd rules parsing rewrite in v243 broke SECLABEL parsing,
-with the result being that udevd crashes when it parses a line
-containing a SECLABEL token. Fix the handling of the attribute
-of SECLABEL tokens when parsing, and add a check to prevent
-crashes if the attribute is missing.
-
-Upstream-Status: Pending
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/src/udev/udev-rules.c b/src/udev/udev-rules.c
-index efea16e5c5..3e757ccb06 100644
---- a/src/udev/udev-rules.c
-+++ b/src/udev/udev-rules.c
-@@ -918,7 +918,7 @@ static int parse_token(UdevRules *rules, const char *key, char *attr, UdevRuleOp
-                         op = OP_ASSIGN;
-                 }
--                r = rule_line_add_token(rule_line, TK_A_SECLABEL, op, value, NULL);
-+                r = rule_line_add_token(rule_line, TK_A_SECLABEL, op, value, attr);
-         } else if (streq(key, "RUN")) {
-                 if (is_match || op == OP_REMOVE)
-                         return log_token_invalid_op(rules, key);
-@@ -1927,6 +1927,8 @@ static int udev_rule_apply_token_to_event(
-                 _cleanup_free_ char *name = NULL, *label = NULL;
-                 char label_str[UTIL_LINE_SIZE] = {};
-+                if (!token->data)
-+                        break;
-                 name = strdup((const char*) token->data);
-                 if (!name)
-                         return log_oom();
index 242b3d3..96c4dc3 100644 (file)
@@ -1,7 +1,6 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
 SRC_URI += "\
-    file://0001-fix-udevd-seclabel-parsing.patch \
     file://0002-network-add-CAN-Termination-tristate-option.patch \
     file://e2fsck.conf \
     file://canbus-can.network \