meta-agl: sifive unmatched: add radeon drivers for gfx 52/29252/2
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 28 Sep 2023 19:59:39 +0000 (21:59 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 3 Oct 2023 19:48:59 +0000 (19:48 +0000)
Add the amd / radeon drivers for pci-e gfx support.

Bug-AGL: SPEC-4909
Change-Id: I91e17f378a84dd7ab767495352c289e4e6ba3fa6
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29252
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

meta-agl-bsp/meta-sifive/recipes-kernel/linux/linux-sifive/radeon.cfg [new file with mode: 0644]
meta-agl-bsp/meta-sifive/recipes-kernel/linux/linux-sifive_%.bbappend [new file with mode: 0644]

diff --git a/meta-agl-bsp/meta-sifive/recipes-kernel/linux/linux-sifive/radeon.cfg b/meta-agl-bsp/meta-sifive/recipes-kernel/linux/linux-sifive/radeon.cfg
new file mode 100644 (file)
index 0000000..fd25fdd
--- /dev/null
@@ -0,0 +1,19 @@
+CONFIG_MOUSE_PS2_SYNAPTICS_SMBUS=y
+CONFIG_MOUSE_PS2_SMBUS=y
+CONFIG_I2C=y
+CONFIG_I2C_ALGOBIT=y
+CONFIG_DRM_BUDDY=m
+CONFIG_DRM_SCHED=m
+CONFIG_DRM_AMDGPU=m
+CONFIG_DRM_AMD_DC=y
+CONFIG_FB_DDC=y
+CONFIG_FB_CFB_FILLRECT=y
+CONFIG_FB_CFB_COPYAREA=y
+CONFIG_FB_CFB_IMAGEBLIT=y
+CONFIG_FB_BACKLIGHT=y
+CONFIG_FB_MODE_HELPERS=y
+CONFIG_FB_RADEON=y
+CONFIG_FB_RADEON_I2C=y
+CONFIG_FB_RADEON_BACKLIGHT=y
+CONFIG_BACKLIGHT_CLASS_DEVICE=y
+CONFIG_RTC_I2C_AND_SPI=y
\ No newline at end of file
diff --git a/meta-agl-bsp/meta-sifive/recipes-kernel/linux/linux-sifive_%.bbappend b/meta-agl-bsp/meta-sifive/recipes-kernel/linux/linux-sifive_%.bbappend
new file mode 100644 (file)
index 0000000..d951b33
--- /dev/null
@@ -0,0 +1,6 @@
+require recipes-kernel/linux/linux-agl.inc
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
+
+# enable AMDgpu 
+AGL_KCONFIG_FRAGMENTS += "radeon.cfg"