Add uvc.cfg for usb video class kernel configure 93/10893/3
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>
Thu, 14 Sep 2017 08:43:18 +0000 (17:43 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 18 Sep 2017 03:46:30 +0000 (03:46 +0000)
    Add uvc.cfg into meta-agl-bsp/recipes-kernel,
    Then include this cfg in each board bbappend.
    See: https://gerrit.automotivelinux.org/gerrit/#/c/10803/

Change-Id: I5faebefef3560a27496103e1ad4a1ca70377a1ba
Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10893
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc-imx_%.bbappend
meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.4%.bbappend
meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.9%.bbappend
meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt_4.9.bbappend
meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend
meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
meta-agl-bsp/recipes-kernel/linux/linux-%.bbappend
meta-agl-bsp/recipes-kernel/linux/linux/uvc.cfg [new file with mode: 0644]

index 5fe15cb..bed10fa 100644 (file)
@@ -101,3 +101,5 @@ KERNEL_CONFIG_FRAGMENTS_append_smack = "\
        ${WORKDIR}/smack-default-lsm.cfg \
 "
 
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
index 2606347..68149e5 100644 (file)
@@ -18,3 +18,6 @@ SRC_URI_prepend_intel-corei7-64 = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE',
 KERNEL_FEATURES_remove_corei7-64-intel-common = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'features/amt/mei/mei.scc', '', d)}"
 KERNEL_FEATURES_append_corei7-64-intel-common = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', ' features/mei/mei-spd.scc', '', d)}"
 SRC_URI_append = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', ' file://security-tpm.cfg', '', d)}"
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
index 65484da..d524ebf 100644 (file)
@@ -7,3 +7,6 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usb-devices.cfg"
 # adding support for other graphic cards to work on more PC HW
 SRC_URI_append = " file://extra-graphic-devices.cfg"
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
index 854b759..77a1544 100644 (file)
@@ -28,3 +28,6 @@ KERNEL_CONFIG_FRAGMENTS_append_smack = "\
 
 # file comes out of  meta-agl-bsp/recipes-kernel/linux/linux_%.bbappend
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/can-bus.cfg"
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
\ No newline at end of file
index ead116b..753440a 100644 (file)
@@ -103,3 +103,6 @@ KERNEL_MODULE_AUTOLOAD += "hid-multitouch"
 
 RDEPENDS_${PN} += "kernel-module-snd-bcm2835"
 PACKAGES += "kernel-module-snd-bcm2835"
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
index 93a060e..c3fb205 100644 (file)
@@ -7,3 +7,6 @@ SRC_URI_append  = " file://namespace_fix.cfg \
        file://ath9k_htc.cfg \
        file://disable_ipv6.cfg \
        "
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
index 368f1ba..0871fbf 100755 (executable)
@@ -42,3 +42,6 @@ KERNEL_CONFIG_FRAGMENTS_append_agl-porter-hibernate += " ${WORKDIR}/hibernation/
 
 # file comes out of  meta-agl-bsp/recipes-kernel/linux/linux_%.bbappend
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/can-bus.cfg"
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
\ No newline at end of file
index b2e5431..f9c0c04 100644 (file)
@@ -31,3 +31,6 @@ KERNEL_CONFIG_FRAGMENTS_append_smack = "\
 
 # file comes out of  meta-agl-bsp/recipes-kernel/linux/linux_%.bbappend
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/can-bus.cfg"
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
index f5e01e2..04aeb94 100644 (file)
@@ -3,4 +3,5 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux:"
 # Extra configuration options for the AGL kernel
 SRC_URI_append = " file://can-bus.cfg \
                    file://usb.cfg \
+                   file://uvc.cfg \
             "
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux/uvc.cfg b/meta-agl-bsp/recipes-kernel/linux/linux/uvc.cfg
new file mode 100644 (file)
index 0000000..7cfc377
--- /dev/null
@@ -0,0 +1,4 @@
+CONFIG_VIDEOBUF2_VMALLOC=y
+CONFIG_MEDIA_USB_SUPPORT=y
+CONFIG_USB_VIDEO_CLASS=y
+CONFIG_USB_VIDEO_CLASS_INPUT_EVDEV=y