Remove inactive devices 31/21031/4
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Sat, 13 Apr 2019 22:18:07 +0000 (00:18 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 29 Apr 2019 11:41:03 +0000 (11:41 +0000)
Remove device which are EOL, unused or do not work.

As discussed during the SAT call:

- rpi2 :
 -- will not work for IVI due to the CPU
 -- use the rpi3 instead

- joule :
 -- EOL for ~1y, no longer available for purchase, no way to test.

i.MX6:
Remove currently unmaintaned boards. Can re-add on request.
- imx6qsabrelite:
 -- replaced with uprev'd imx6qsabreauto -> imx6qdlsabreauto
- nitrogen6x:
 -- no thud branch upstream.

Bug-AGL: SPEC-2323

Change-Id: I28a70dcb7b48b6a9396d3003cc34d4c1f6570eca
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
14 files changed:
meta-agl-bsp/conf/include/agl_imx6qsabrelite.inc [deleted file]
meta-agl-bsp/conf/include/agl_joule.inc [deleted file]
meta-agl-bsp/conf/include/agl_nitrogen6x.inc [deleted file]
meta-agl-bsp/conf/include/agl_raspberrypi2.inc [deleted file]
templates/machine/imx6qsabrelite/40_bblayers.conf.inc [deleted file]
templates/machine/imx6qsabrelite/50_local.conf.inc [deleted file]
templates/machine/imx6qsabrelite/50_setup.sh [deleted file]
templates/machine/joule/50_bblayers.conf.inc [deleted file]
templates/machine/joule/50_local.conf.inc [deleted file]
templates/machine/nitrogen6x/40_bblayers.conf.inc [deleted file]
templates/machine/nitrogen6x/50_local.conf.inc [deleted file]
templates/machine/nitrogen6x/50_setup.sh [deleted file]
templates/machine/raspberrypi2/50_bblayers.conf.inc [deleted file]
templates/machine/raspberrypi2/50_local.conf.inc [deleted file]

diff --git a/meta-agl-bsp/conf/include/agl_imx6qsabrelite.inc b/meta-agl-bsp/conf/include/agl_imx6qsabrelite.inc
deleted file mode 100644 (file)
index e686a40..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-IMAGE_INSTALL_append = " \
-    packagegroup-fsl-tools-gpu \
-    packagegroup-fsl-gstreamer1.0 \
-    packagegroup-imx-tools-audio \
-    weston weston-init weston-examples \
-"
-
-# fsl-image-multimedia-full.bb
-IMAGE_INSTALL_append = " \
-    packagegroup-fsl-gstreamer1.0-full \
-"
-
-# prevent of build errors from missing bb files
-BBMASK = "meta-boundary/recipes-(browser|mozilla)"
-
-# fix build error
-SECURITY_CFLAGS_pn-devil = "${SECURITY_NO_PIE_CFLAGS}"
-
-PREFERRED_PROVIDER_virtual/kernel = "linux-boundary"
-
-PREFERRED_PROVIDER_u-boot = "u-boot-boundary"
-PREFERRED_PROVIDER_virtual/bootloader = "u-boot-boundary"
-PREFERRED_PROVIDER_u-boot-mxsboot-native = "u-boot-boundary"
-MACHINE_ESSENTIAL_EXTRA_RDEPENDS += " \
-       u-boot-boundary \
-       u-boot-script-boundary \
-"
-
-UBOOT_MACHINE = "nitrogen6q_config"
-SPL_BINARY = ""
-UBOOT_SUFFIX_SDCARD = "imx"
-IMAGE_BOOTLOADER = "u-boot"
-
-# generate WIC image also
-WKS_FILE = "imx-uboot.wks"
-AGL_EXTRA_IMAGE_FSTYPES = "wic.xz wic.bmap wic.xz.sha256sum"
-AGL_DEFAULT_INITRAMFS_FSTYPES := ""
-
-PREFERRED_VERSION_weston_mx6_forcevariable = "2.0.0"
diff --git a/meta-agl-bsp/conf/include/agl_joule.inc b/meta-agl-bsp/conf/include/agl_joule.inc
deleted file mode 100644 (file)
index 642fe42..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-INTEL_MACHINE_SUBTYPE = "broxton-m"
-
-IMAGE_INSTALL_append = " linux-firmware-iwlwifi-8000c linux-firmware-ibt"
-IMAGE_INSTALL_append = " \
-        libva \
-        intel-vaapi-driver \
-        gstreamer1.0-vaapi"
-OSTREE_BOOTLOADER ?= "u-boot"
-
-AGL_EXTRA_IMAGE_FSTYPES = "wic.xz wic.bmap wic.xz.sha256sum"
-INITRD_LIVE = "${DEPLOY_DIR_IMAGE}/${INITRD_IMAGE_LIVE}-${MACHINE}.ext4.gz"
-# Modify this file under meta-agl-bsp/meta-intel/wic to change the
-# kernel command line
-WKS_FILE = "systemd-joule-bootdisk.wks"
diff --git a/meta-agl-bsp/conf/include/agl_nitrogen6x.inc b/meta-agl-bsp/conf/include/agl_nitrogen6x.inc
deleted file mode 100644 (file)
index 9f23453..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-PREFERRED_PROVIDER_u-boot = "u-boot-imx6"
-PREFERRED_PROVIDER_virtual/bootloader = "u-boot-imx6"
-PREFERRED_PROVIDER_u-boot-mxsboot-native = "u-boot-imx6"
-
-AGL_DEFAULT_IMAGE_FSTYPES = "sdcard.gz"
-
-# prevent of build errors from missing bb files
-BBMASK = "meta-boundary/recipes-(browser|mozilla)"
-
-PREFERRED_VERSION_weston_mx6_forcevariable = "2.0.0"
diff --git a/meta-agl-bsp/conf/include/agl_raspberrypi2.inc b/meta-agl-bsp/conf/include/agl_raspberrypi2.inc
deleted file mode 100644 (file)
index a474652..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-# Maximum memory allowed to be assigned
-GPU_MEM = "255"
-
-ENABLE_CMA = "1"
-CMA_LWM = "16"
-CMA_HWM = "32"
-
-CORE_IMAGE_EXTRA_INSTALL += "wayland weston"
-
-MULTI_PROVIDER_WHITELIST += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
-
-KERNEL_IMAGETYPE = "uImage"
-KERNEL_DEVICETREE_append = " overlays/vc4-kms-v3d-overlay.dtb"
-PREFERRED_VERSION_mesa = "12.%"
-
-PREFERRED_PROVIDER_virtual/egl = "mesa"
-PREFERRED_PROVIDER_virtual/libgles2 = "mesa"
-PREFERRED_PROVIDER_virtual/libgl = "mesa"
-PREFERRED_PROVIDER_virtual/mesa = "mesa"
-PREFERRED_PROVIDER_jpeg = "jpeg"
-
-MACHINE_FEATURES += "vc4graphics"
-
-# For libomxil
-#LICENSE_FLAGS_WHITELIST = "commercial"
-
-IMAGE_INSTALL_append = " kernel-modules linux-firmware "
-
-# Psplash causes crash on first boot on RPi
-IMAGE_FEATURES_remove = "splash"
-
-# Build updatable image. Only takes effect when sota.bbclass is inherited
-DISTRO_FEATURES_append = " sota"
-
-# Create WIC images to write to SD cards.
-WKS_FILE = "sdimage-raspberrypi.wks"
-AGL_EXTRA_IMAGE_FSTYPES = "wic.xz wic.bmap wic.xz.sha256sum"
-IMAGE_BOOT_FILES = "bcm2835-bootfiles/* \
-                 ${@make_dtb_boot_files(d)} \
-                 ${@bb.utils.contains('KERNEL_IMAGETYPE', 'uImage', \
-                    '${KERNEL_IMAGETYPE} u-boot.bin;${SDIMG_KERNELIMAGE} boot.scr', \
-                    '${KERNEL_IMAGETYPE};${SDIMG_KERNELIMAGE}', d)} \
-                 "
-do_image_wic[depends] += " \
-    bcm2835-bootfiles:do_deploy \
-    ${@bb.utils.contains('KERNEL_IMAGETYPE', 'uImage', 'u-boot:do_deploy', '',d)} \
-    "
diff --git a/templates/machine/imx6qsabrelite/40_bblayers.conf.inc b/templates/machine/imx6qsabrelite/40_bblayers.conf.inc
deleted file mode 100644 (file)
index 2377ff6..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-BBLAYERS =+ "\
-  ${METADIR}/meta-freescale \
-  ${METADIR}/meta-freescale-3rdparty \
-  ${METADIR}/meta-freescale-distro \
-  ${METADIR}/meta-boundary \
-  "
diff --git a/templates/machine/imx6qsabrelite/50_local.conf.inc b/templates/machine/imx6qsabrelite/50_local.conf.inc
deleted file mode 100644 (file)
index 72700cc..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-MACHINE = "imx6qsabrelite"
-require conf/include/agl_imx6qsabrelite.inc
diff --git a/templates/machine/imx6qsabrelite/50_setup.sh b/templates/machine/imx6qsabrelite/50_setup.sh
deleted file mode 100644 (file)
index bb22790..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-find_and_ack_eula $METADIR/meta-freescale EULA
-export EULA_FLAG_NAME="ACCEPT_FSL_EULA"
diff --git a/templates/machine/joule/50_bblayers.conf.inc b/templates/machine/joule/50_bblayers.conf.inc
deleted file mode 100644 (file)
index d50ccc9..0000000
+++ /dev/null
@@ -1 +0,0 @@
-BBLAYERS =+ "${METADIR}/meta-intel"
diff --git a/templates/machine/joule/50_local.conf.inc b/templates/machine/joule/50_local.conf.inc
deleted file mode 100644 (file)
index 04b7e6f..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MACHINE = "intel-corei7-64"
-#see meta-agl/meta-agl-bsp/conf/include/agl_joule.inc
-require conf/include/agl_joule.inc
diff --git a/templates/machine/nitrogen6x/40_bblayers.conf.inc b/templates/machine/nitrogen6x/40_bblayers.conf.inc
deleted file mode 100644 (file)
index 2377ff6..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-BBLAYERS =+ "\
-  ${METADIR}/meta-freescale \
-  ${METADIR}/meta-freescale-3rdparty \
-  ${METADIR}/meta-freescale-distro \
-  ${METADIR}/meta-boundary \
-  "
diff --git a/templates/machine/nitrogen6x/50_local.conf.inc b/templates/machine/nitrogen6x/50_local.conf.inc
deleted file mode 100644 (file)
index e013355..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MACHINE = "nitrogen6x"
-require conf/include/agl_nitrogen6x.inc
-
diff --git a/templates/machine/nitrogen6x/50_setup.sh b/templates/machine/nitrogen6x/50_setup.sh
deleted file mode 100644 (file)
index bb22790..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-find_and_ack_eula $METADIR/meta-freescale EULA
-export EULA_FLAG_NAME="ACCEPT_FSL_EULA"
diff --git a/templates/machine/raspberrypi2/50_bblayers.conf.inc b/templates/machine/raspberrypi2/50_bblayers.conf.inc
deleted file mode 100644 (file)
index 1250b35..0000000
+++ /dev/null
@@ -1 +0,0 @@
-BBLAYERS =+ "${METADIR}/meta-raspberrypi"
diff --git a/templates/machine/raspberrypi2/50_local.conf.inc b/templates/machine/raspberrypi2/50_local.conf.inc
deleted file mode 100644 (file)
index 5d314ee..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-MACHINE = "raspberrypi2"
-#see meta-agl/meta-agl-bsp/conf/include/agl_raspberrypi2.inc
-require conf/include/agl_raspberrypi2.inc