agl-compositor_git: Bump SRCREV 42/26442/8
authorMarius Vlad <marius.vlad@collabora.com>
Tue, 22 Jun 2021 10:19:45 +0000 (12:19 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 30 Jul 2021 12:25:08 +0000 (12:25 +0000)
This bump brings no functional change, it just re-factors some of the
code in the compositor to match a bit more to what upstreaming into has
in weston, and paves the way to add support for testing, and with it, to
include headless backend loading. The bump would need changes in the
recipe so it will have a couple of follows-up, to compile the headless
back-end and install a run-time shared library.

Note this change squashed headless-backend support as well to make CI
happy (Bug-AGL: SPEC-3964) and Install the run-time shared library (Bug-AGL: SPEC-3964)

In more detail, the following changes have been included:

de7cdb0314af949 compositor: Avoid loading systemd-notify plug-in
ae60166cd931609 meson.build: Install run-time shared library to a specific path
0bef8700f21b9e7 main: Split of main() from wet_main()
65361f9f7979056 main: Copy cmd line args and print them
ccda88821b5bd9a main: Teach agl-compositor to load additional modules
61dff3ff317c4d6 main: Add support for loading the headless-backend

Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: I49bbb216cb723db6a104d9e2753f5ddeb9bdd9f0
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26442
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-core/recipes-graphics/wayland/agl-compositor_git.bb
meta-agl-core/recipes-graphics/wayland/weston_8.0_aglcore.inc

index cdc781a..fe565c0 100644 (file)
@@ -12,7 +12,7 @@ DEPENDS = "wayland wayland-protocols wayland-native weston \
           ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/agl-compositor.git;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "68d184f9d541a475e15727d71f49b6df6799a054"
+SRCREV = "de7cdb0314af94939b8d57e10afc2a1553ae82da"
 
 PV = "0.0.10+git${SRCPV}"
 S = "${WORKDIR}/git"
@@ -26,6 +26,8 @@ inherit meson pkgconfig python3native
 FILES_${PN} = " \
     ${bindir}/agl-compositor \
     ${bindir}/agl-screenshooter \
+    ${libdir}/agl-compositor/libexec_compositor.so.0 \
+    ${libdir}/agl-compositor/libexec_compositor.so.0.0.0 \
 "
 
 RDEPENDS_${PN} += " ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'waltham waltham-transmitter-plugin', '', d)}"
@@ -33,4 +35,5 @@ RDEPENDS_${PN} += " ${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', 'wa
 FILES_${PN}-dev += " \
     ${datadir}/agl-compositor/protocols/agl-shell.xml \
     ${datadir}/agl-compositor/protocols/agl-shell-desktop.xml \
+    ${libdir}/agl-compositor/libexec_compositor.so \
 "
index 3c9bd4d..d7c15e2 100644 (file)
@@ -6,6 +6,8 @@ SRC_URI_append = "\
 
 # Workaround for incorrect upstream definition
 PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
+PACKAGECONFIG[remoting] = "-Dremoting=true,-Dremoting=false,gstreamer1.0 gstreamer1.0-plugins-base"
+PACKAGECONFIG[headless] = "-Dbackend-headless=true"
 PACKAGECONFIG_append = "${@bb.utils.contains('DISTRO_FEATURES', 'weston-remoting', ' remoting', '', d)}"
 PACKAGECONFIG_append = "${@bb.utils.contains('AGL_FEATURES', 'waltham-remoting', ' remoting', '', d)}"