meta-agl-core: add recipe for librba and rba-config 21/25821/11
authorAnusha Gugale <external.agogale@jp.adit-jv.com>
Thu, 17 Dec 2020 07:27:48 +0000 (12:57 +0530)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 12 Jan 2021 20:41:47 +0000 (20:41 +0000)
- Required for agl-compositor rba policy
- RBAModel.json will be install using rba-config recipe file

  Bug-AGL: SPEC-3738

Signed-off-by: Anusha Gugale <external.agogale@jp.adit-jv.com>
Change-Id: I05244dcceb8f0ba56865ce1edf1563b90bdfbae3
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25821
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-core/recipes-graphics/rba/librba_1.0.bb [new file with mode: 0644]
meta-agl-core/recipes-graphics/rba/rba-config.bb [new file with mode: 0644]
meta-agl-core/recipes-graphics/rba/rba-config/RBAModel.json [new file with mode: 0644]

diff --git a/meta-agl-core/recipes-graphics/rba/librba_1.0.bb b/meta-agl-core/recipes-graphics/rba/librba_1.0.bb
new file mode 100644 (file)
index 0000000..450684f
--- /dev/null
@@ -0,0 +1,24 @@
+SUMMARY = "RBA"
+DESCRIPTION = "Rule Based Arbitrator decides which of the content to display \
+when a large number of contents to be displayed on the cockpit display device \
+(CID, meter, HUD, etc.) occur simultaneously under a certain rule (arbitration)"
+
+SECTION = "libs"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=13afa517927767fe9b7a65818a02bd8f"
+
+INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/rba;protocol=https;branch=master"
+SRCREV = "2cfe2c611be63ae4541abf4e13cfecff0f008f25"
+
+S = "${WORKDIR}/git"
+
+inherit pkgconfig cmake
+
+FILES_${PN} = "${libdir}/"
+FILES_${PN}-dev = "${libdir}/pkgconfig/librba.pc \
+                   ${includedir}/ \
+                  "
+INSANE_SKIP_${PN} += "dev-so"
+INSANE_SKIP_${PN}-dev += "dev-elf"
diff --git a/meta-agl-core/recipes-graphics/rba/rba-config.bb b/meta-agl-core/recipes-graphics/rba/rba-config.bb
new file mode 100644 (file)
index 0000000..17b7a67
--- /dev/null
@@ -0,0 +1,15 @@
+SUMMARY = "Rule Based Arbitrator Model required for RBA policy compositor."
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "file://RBAModel.json"
+
+S = "${WORKDIR}"
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install_append() {
+    install -d ${D}/${sysconfdir}/rba
+    install -m 0644 ${WORKDIR}/RBAModel.json ${D}/${sysconfdir}/rba
+}
diff --git a/meta-agl-core/recipes-graphics/rba/rba-config/RBAModel.json b/meta-agl-core/recipes-graphics/rba/rba-config/RBAModel.json
new file mode 100644 (file)
index 0000000..eb611fa
--- /dev/null
@@ -0,0 +1,300 @@
+{
+       "root":{
+               "model":"",
+               "template":"02.00.00",
+               "areas":[
+               {
+                       "name":"ApplicationArea",
+                       "visibility":-1,
+                       "arbitrationPolicy":"DEFAULT",
+                       "zorder":1,
+                       "size":[
+                       {
+                               "name":"ApplicationSize",
+                               "width":1080,
+                               "height":1488
+                       }
+                       ]
+               },
+               {
+                       "name":"ShortcutIconArea",
+                       "visibility":-1,
+                       "arbitrationPolicy":"DEFAULT",
+                       "zorder":0,
+                       "size":[
+                       {
+                               "name":"ShortcutIconSize",
+                               "width":1080,
+                               "height":216
+                       }
+                       ]
+               }
+               ],
+               "viewcontents":[
+               {
+                       "name":"launcher",
+                       "loserType":"NEVER_GIVEUP",
+                       "size":[
+                       {
+                               "name":"ApplicationSize:Area",
+                               "width":1080,
+                               "height":1488
+                       }
+                       ],
+                       "states":[
+                       {
+                               "name":"NORMAL",
+                               "priority":10
+                       }
+                       ],
+                       "allocatable":[
+                               "ApplicationArea:Area"
+                       ]
+               },
+               {
+                       "name":"dashboard",
+                       "loserType":"NEVER_GIVEUP",
+                       "size":[
+                       {
+                               "name":"ApplicationSize",
+                               "width":1080,
+                               "height":1488
+                       }
+                       ],
+                       "states":[
+                       {
+                               "name":"NORMAL",
+                               "priority":10
+                       }
+                       ],
+                       "allocatable":[
+                               "ApplicationArea:Area"
+                       ]
+               },
+               {
+                       "name":"hvac",
+                       "loserType":"NEVER_GIVEUP",
+                       "size":[
+                       {
+                               "name":"ApplicationSize:Area",
+                               "width":1080,
+                               "height":1488
+                       }
+                       ],
+                       "states":[
+                       {
+                               "name":"NORMAL",
+                               "priority":10
+                       }
+                       ],
+                       "allocatable":[
+                               "ApplicationArea:Area"
+                       ]
+               },
+               {
+                       "name":"mediaplayer",
+                       "loserType":"NEVER_GIVEUP",
+                       "size":[
+                       {
+                               "name":"ApplicationSize:Area",
+                               "width":1080,
+                               "height":1488
+                       }
+                       ],
+                       "states":[
+                       {
+                               "name":"NORMAL",
+                               "priority":10
+                       }
+                       ],
+                       "allocatable":[
+                               "ApplicationArea:Area"
+                       ]
+               },
+               {
+                       "name":"messaging",
+                       "loserType":"NEVER_GIVEUP",
+                       "size":[
+                       {
+                               "name":"ApplicationSize:Area",
+                               "width":1080,
+                               "height":1488
+                       }
+                       ],
+                       "states":[
+                       {
+                               "name":"NORMAL",
+                               "priority":10
+                       }
+                       ],
+                       "allocatable":[
+                               "ApplicationArea:Area"
+                       ]
+               },
+               {
+                       "name":"mixer",
+                       "loserType":"NEVER_GIVEUP",
+                       "size":[
+                       {
+                               "name":"ApplicationSize:Area",
+                               "width":1080,
+                               "height":1488
+                       }
+                       ],
+                       "states":[
+                       {
+                               "name":"NORMAL",
+                               "priority":10
+                       }
+                       ],
+                       "allocatable":[
+                               "ApplicationArea:Area"
+                       ]
+               },
+               {
+                       "name":"navigation",
+                       "loserType":"NEVER_GIVEUP",
+                       "size":[
+                       {
+                               "name":"ApplicationSize:Area",
+                               "width":1080,
+                               "height":1488
+                       }
+                       ],
+                       "states":[
+                       {
+                               "name":"NORMAL",
+                               "priority":10
+                       }
+                       ],
+                       "allocatable":[
+                               "ApplicationArea:Area"
+                       ]
+               },
+               {
+                       "name":"phone",
+                       "loserType":"NEVER_GIVEUP",
+                       "size":[
+                       {
+                               "name":"ApplicationSize:Area",
+                               "width":1080,
+                               "height":1488
+                       }
+                       ],
+                       "states":[
+                       {
+                               "name":"NORMAL",
+                               "priority":10
+                       }
+                       ],
+                       "allocatable":[
+                               "ApplicationArea:Area"
+                       ]
+               },
+               {
+                       "name":"poi",
+                       "loserType":"NEVER_GIVEUP",
+                       "size":[
+                       {
+                               "name":"ApplicationSize:Area",
+                               "width":1080,
+                               "height":1488
+                       }
+                       ],
+                       "states":[
+                       {
+                               "name":"NORMAL",
+                               "priority":10
+                       }
+                       ],
+                       "allocatable":[
+                               "ApplicationArea:Area"
+                       ]
+               },
+               {
+                       "name":"radio",
+                       "loserType":"NEVER_GIVEUP",
+                       "size":[
+                       {
+                               "name":"ApplicationSize:Area",
+                               "width":1080,
+                               "height":1488
+                       }
+                       ],
+                       "states":[
+                       {
+                               "name":"NORMAL",
+                               "priority":10
+                       }
+                       ],
+                       "allocatable":[
+                               "ApplicationArea:Area"
+                       ]
+               },
+               {
+                       "name":"settings",
+                       "loserType":"NEVER_GIVEUP",
+                       "size":[
+                       {
+                               "name":"ApplicationSize:Area",
+                               "width":1080,
+                               "height":1488
+                       }
+                       ],
+                       "states":[
+                       {
+                               "name":"NORMAL",
+                               "priority":10
+                       }
+                       ],
+                       "allocatable":[
+                               "ApplicationArea:Area"
+                       ]
+               },
+               {
+                       "name":"taskmanager",
+                       "loserType":"NEVER_GIVEUP",
+                       "size":[
+                       {
+                               "name":"ApplicationSize:Area",
+                               "width":1080,
+                               "height":1488
+                       }
+                       ],
+                       "states":[
+                       {
+                               "name":"NORMAL",
+                               "priority":10
+                       }
+                       ],
+                       "allocatable":[
+                               "ApplicationArea:Area"
+                       ]
+               }
+               ],
+               "displays":[
+               {
+                       "name":"SampleDisplay",
+                       "size":{
+                               "name":"FULLSCREEN",
+                               "width":1080,
+                               "height":1920
+                       },
+                       "PositionContainer":[
+                       {
+                               "x":0,
+                               "y":0,
+                               "basePoint":"LEFT_TOP",
+                               "areaReference":"ShortcutIconArea"
+                       },
+                       {
+                               "x":0,
+                               "y":216,
+                               "basePoint":"LEFT_TOP",
+                               "areaReference":"ApplicationArea"
+                       }
+                       ]
+               }
+               ]
+       }
+}