weston: Remove user session login for weston 94/21594/7
authorJosé Bollo <jose.bollo@iot.bzh>
Tue, 14 May 2019 14:11:58 +0000 (16:11 +0200)
committerJosé Bollo <jose.bollo@iot.bzh>
Fri, 14 Jun 2019 09:22:13 +0000 (09:22 +0000)
Before that commit, the service weston was started as
user 'display' with a full setup of the user.
It means that all services normally started for user
started for weston: systemd-user, dbus, afm-user-daemon,
lightmediascanner (that is all at the moment). This is
useless and grabs resources.

This commit avoids to start a session for weston.
This saves resources. This changes is part of a set
of changes to run services as not root.

Bug-AGL: SPEC-545
Bug-AGL: SPEC-2492

Change-Id: If51d8fdf8c5e19d10151a2b96a79dc01bbb8ccb4
Signed-off-by: José Bollo <jose.bollo@iot.bzh>
meta-agl-profile-graphical/recipes-graphics/wayland/weston-init.bbappend

index 1ca63b5..910cf5a 100644 (file)
@@ -2,6 +2,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
 inherit agl-graphical
 
+
 WESTONSTART ??= "/usr/bin/weston ${WESTONARGS}"
 WESTONSTART_append = " ${@bb.utils.contains("IMAGE_FEATURES", "debug-tweaks", " --log=${DISPLAY_XDG_RUNTIME_DIR}/weston.log", "",d)}"
 
@@ -29,6 +30,7 @@ do_install_append() {
         -e 's,ExecStart=.*,ExecStart=${WESTONSTART},g' \
         -e 's,@WESTONTTY@,${WESTONTTY},g' \
         -e 's,@XDG_RUNTIME_DIR@,${DISPLAY_XDG_RUNTIME_DIR},g' \
+       -e '/PAMName=/d' \
         -i ${D}${systemd_system_unitdir}/weston.service
 
     # Add a rule to ensure the 'display' user has permissions to