meta-renesas: update gstreamer version workaround 66/26066/3
authorScott Murray <scott.murray@konsulko.com>
Wed, 10 Feb 2021 18:23:15 +0000 (13:23 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 17 Feb 2021 22:50:54 +0000 (22:50 +0000)
The wildcard bbappends added as a workaround for gstreamer 1.16.3
versus 1.16.2 for the dunfell 3.1.4 upgrade (SPEC-3706) were less
than ideal since they still pointed at the 1.16.2 branch in Renesas'
repositories.  They have advised that 1.16.3 support branches are
now available, so update the workaround bbappends to use them, and
change the wildcard usage back to the full version number.

This should hold us until the BSP v4.1.7 update, when these bbappends
can be removed.

Bug-AGL: SPEC-3803

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I56e6699dce8b45f3c5f713958c43b9bbc8af8ec6
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26039
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
(cherry picked from commit 0fcc99e2b74b7e393980c2e3bfe9863b5dbc8ae4)
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26066
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16.3.bbappend [moved from meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.16.%.bbappend with 94% similarity]
meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.3.bbappend [moved from meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.%.bbappend with 71% similarity]
meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.3.bbappend [moved from meta-agl-bsp/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.16.%.bbappend with 79% similarity]

@@ -2,7 +2,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}/:"
 
 SRC_URI_remove = "http://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${PV}.tar.xz"
 SRC_URI_append = " \
-    gitsm://github.com/renesas-rcar/gst-omx.git;branch=RCAR-GEN3/1.16.2 \
+    gitsm://github.com/renesas-rcar/gst-omx.git;branch=RCAR-GEN3/1.16.3 \
     file://gstomx.conf \
 "
 
@@ -10,7 +10,7 @@ require include/rcar-gen3-path-common.inc
 
 DEPENDS += "omx-user-module mmngrbuf-user-module"
 
-SRCREV = "d4d1cc35222e8c0cc1b84a3c96a3915e1b0ed199"
+SRCREV = "d9748c48c75e8c108af0300d9f452282d266ebd5"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
     file://omx/gstomx.h;beginline=1;endline=22;md5=e2c6664eda77dc22095adbed9cb6c6e4 \
@@ -1,7 +1,7 @@
 SRC_URI_remove = "http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-${PV}.tar.xz"
-SRC_URI_append = " gitsm://github.com/renesas-rcar/gst-plugins-bad.git;branch=RCAR-GEN3/1.16.2"
+SRC_URI_append = " gitsm://github.com/renesas-rcar/gst-plugins-bad.git;branch=RCAR-GEN3/1.16.3"
 
-SRCREV = "4459dc7686a2c20ed9097734e11d17631f71105a"
+SRCREV = "3ef17d3c57e12f9d7536e464656b871a8949fa5b"
 
 DEPENDS += "weston"
 
@@ -1,7 +1,7 @@
 SRC_URI_remove = "http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz"
-SRC_URI_append = " gitsm://github.com/renesas-rcar/gst-plugins-good.git;branch=RCAR-GEN3/1.16.2"
+SRC_URI_append = " gitsm://github.com/renesas-rcar/gst-plugins-good.git;branch=RCAR-GEN3/1.16.3"
 
-SRCREV = "72bafddb123541ed1c892a5eb4989591ca4efd49"
+SRCREV = "ca2036d2b09a434adc52aa02890c1503bf7100bf"
 
 DEPENDS += "mmngrbuf-user-module"