meta-agl-bsp: add kernel-devicetree to nogfx rcar3 images 81/25781/2
authorScott Murray <scott.murray@konsulko.com>
Tue, 5 Jan 2021 23:49:47 +0000 (18:49 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 11 Jan 2021 17:20:55 +0000 (17:20 +0000)
Shift the IMAGE_INSTALL_append of the kernel-devicetree package to
agl_rcar-nogfx.inc so that it will be added to the *ulcb-nogfx images
in addition to the *uclb images.  This fixes booting the nogfx images
from SD cards created with the wic.xz image.

Bug-AGL: SPEC-3754

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: If4868326f50e45046fcce7b5d6ba43f13f746ec1
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25866
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
(cherry picked from commit 47464de6ae327896b2d2e5047275d933010b5eeb)
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25781

meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
meta-agl-bsp/conf/include/agl_rcar.inc

index a7fabfa..3ffded7 100644 (file)
@@ -7,3 +7,7 @@ OSTREE_BOOTLOADER ?= "u-boot"
 WKS_FILE = "singlepart-noloader.wks"
 
 RENESAS_DATADIR = "/usr"
+
+IMAGE_INSTALL_append_rcar-gen3 = " \
+    kernel-devicetree \
+"
\ No newline at end of file
index dd64ae7..cfdff9d 100644 (file)
@@ -41,7 +41,6 @@ DISTRO_FEATURES_append = " h264dec_lib h264enc_lib aaclcdec_lib aaclcdec_mdw"
 BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend"
 
 IMAGE_INSTALL_append_rcar-gen3 = " \
-    kernel-devicetree \
     kernel-module-pvrsrvkm \
     kernel-module-vsp2 \
     kernel-module-vspm  \