Copy metadata for GStreamer1.0 from Yocto GENIVI Baseline 56/4056/2
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Thu, 27 Aug 2015 09:42:22 +0000 (18:42 +0900)
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Mon, 31 Aug 2015 05:30:56 +0000 (05:30 +0000)
There are 2 type of metadata for GStreamer when building
GDP/GENIVI baseline, meta-ivi (7.0).

One is metadata in meta-ivi which is to install ver.1.2.3 ,
the other is in poky/meta is to install ver.1.4.1.

By default, GENIVI baseline preferred 1.4.x by macro
PREFERRED_VERSION_ in poky-ivi-systemd.conf.

As a result, for QEMU, GStreamer1.0_1.4.x is used and it works.

On the other hand, Renesas BSP (proprietary multimedia packages)
requires GStreamer1.0_1.2.x and it override PREFERRED_VERSION_
then select to use 1.2.x instead of 1.4.x.

From the above, AGL Distro also need metadata for GStreamer1.0_1.2.x
to run software on R-Car Gen2 Porter board.

This is the first step to support GStreamer in AGL Distro.

All files in this patch are from:
    URL: git://git.yoctoproject.org/meta-ivi
    commit: 0d780d0cfd38694ae5e6f0198adcb72684b01acc

NOTE: This patch is not completed alone and some error will be
got when building with meta-renesas. Please wait a subsequent patches.

Change-Id: I8ce1ec2b1593fc59780495459afc8c642e2d80d6
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-libav/0001-Disable-yasm-for-libav-when-disable-yasm.patch [new file with mode: 0644]
meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.2.3.bb [new file with mode: 0644]
meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.0.0.bb [new file with mode: 0644]
meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend [new file with mode: 0644]
meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.2.3.bb [new file with mode: 0644]
meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.3.bb [new file with mode: 0644]
meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.2.3.bb [new file with mode: 0644]
meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.2.3.bb [new file with mode: 0644]
meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0/0001-Fix-crash-with-gst-inspect.patch [new file with mode: 0644]
meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0_1.2.3.bb [new file with mode: 0644]

diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-libav/0001-Disable-yasm-for-libav-when-disable-yasm.patch b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-libav/0001-Disable-yasm-for-libav-when-disable-yasm.patch
new file mode 100644 (file)
index 0000000..1d99ad1
--- /dev/null
@@ -0,0 +1,33 @@
+From 54bba228ea52d01fd84941d97be23c03f9862b64 Mon Sep 17 00:00:00 2001
+From: Carlos Rafael Giani <dv@pseudoterminal.org>
+Date: Sat, 6 Apr 2013 01:22:22 +0200
+Subject: [PATCH] Disable yasm for libav when --disable-yasm
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Shane Wang <shane.wang@intel.com>
+Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org>
+---
+ configure.ac | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 22ede88..ef3c050 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -305,6 +305,12 @@ else
+     emblibav_configure_args="$emblibav_configure_args --enable-gpl"
+   fi
+
++  AC_ARG_ENABLE(yasm,
++              [AC_HELP_STRING([--disable-yasm], [disable use of yasm assembler])])
++  if test "x$enable_yasm" = "xno"; then
++    emblibav_configure_args="$emblibav_configure_args --disable-yasm"
++  fi
++
+   # if we are cross-compiling, tell libav so
+   case $host in
+       *android*)
+-- 
+1.8.2
+
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.2.3.bb b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-libav_1.2.3.bb
new file mode 100644 (file)
index 0000000..2e6ed2e
--- /dev/null
@@ -0,0 +1,26 @@
+DEFAULT_PREFERENCE = "-1"
+
+include recipes-multimedia/gstreamer/gstreamer1.0-libav.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+                    file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \
+                    file://ext/libav/gstav.h;beginline=1;endline=18;md5=a752c35267d8276fd9ca3db6994fca9c \
+                    file://gst-libs/ext/libav/LICENSE;md5=23a54f59b82572c203a559346e89ed57 \
+                    file://gst-libs/ext/libav/COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+                    file://gst-libs/ext/libav/COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \
+                    file://gst-libs/ext/libav/COPYING.LGPLv2.1;md5=bd7a443320af8c812e4c18d1b79df004 \
+                    file://gst-libs/ext/libav/COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02"
+
+SRC_URI = " \
+    http://gstreamer.freedesktop.org/src/gst-libav/gst-libav-${PV}.tar.xz \
+    file://0001-Disable-yasm-for-libav-when-disable-yasm.patch \
+    "
+SRC_URI[md5sum] = "58c7998a054d8d8ca041fa35738f72b6"
+SRC_URI[sha256sum] = "ebc7fbe10955f40df6ccc4bf689075e7e296205fc7ecd8ff383d43c5cdf5bcd6"
+LIBAV_EXTRA_CONFIGURE_COMMON_ARG = "--target-os=linux \
+  --cc='${CC}' --as='${CC}' --ld='${CC}' --nm='${NM}' --ar='${AR}' \
+  --ranlib='${RANLIB}' \
+  ${GSTREAMER_1_0_DEBUG}"
+
+S = "${WORKDIR}/gst-libav-${PV}"
+
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.0.0.bb b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-omx_1.0.0.bb
new file mode 100644 (file)
index 0000000..0903f12
--- /dev/null
@@ -0,0 +1,13 @@
+DEFAULT_PREFERENCE = "-1"
+
+include recipes-multimedia/gstreamer/gstreamer1.0-omx.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
+                    file://omx/gstomx.h;beginline=1;endline=21;md5=5c8e1fca32704488e76d2ba9ddfa935f"
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${PV}.tar.xz"
+
+SRC_URI[md5sum] = "bb34b5742223267298bcffc209104a92"
+SRC_URI[sha256sum] = "7a1d8d28d70dacc6bd3c7ee7d7e40df6d5a1d38d7c256d5c9c5c8ef15c005014"
+
+S = "${WORKDIR}/gst-omx-${PV}"
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
new file mode 100644 (file)
index 0000000..e22e3f8
--- /dev/null
@@ -0,0 +1,2 @@
+PACKAGECONFIG[bluez] = "--enable-bluez,--disable-bluez,bluez5"
+
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.2.3.bb b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.2.3.bb
new file mode 100644 (file)
index 0000000..29b8d51
--- /dev/null
@@ -0,0 +1,11 @@
+DEFAULT_PREFERENCE = "-1"
+
+include recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=73a5855a8119deb017f5f13cf327095d \
+                    file://gst/tta/filters.h;beginline=12;endline=29;md5=8a08270656f2f8ad7bb3655b83138e5a \
+                    file://COPYING.LIB;md5=21682e4e8fea52413fd26c60acb907e5 \
+                    file://gst/tta/crc32.h;beginline=12;endline=29;md5=27db269c575d1e5317fffca2d33b3b50"
+SRC_URI[md5sum] = "cfd6f303c8df2740b27cc63b945decef"
+SRC_URI[sha256sum] = "595d7911a9e6207dea37200587724bdbf841b81a5eb0730118be36976684278c"
+S = "${WORKDIR}/gst-plugins-bad-${PV}"
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.3.bb b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.2.3.bb
new file mode 100644 (file)
index 0000000..aa7c448
--- /dev/null
@@ -0,0 +1,11 @@
+DEFAULT_PREFERENCE = "-1"
+
+include recipes-multimedia/gstreamer/gstreamer1.0-plugins-base.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=c54ce9345727175ff66d17b67ff51f58 \
+                    file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \
+                    file://COPYING.LIB;md5=6762ed442b3822387a51c92d928ead0d \
+                   "
+SRC_URI[md5sum] = "17aeabfbcd232526f50c9bee375f1b97"
+SRC_URI[sha256sum] = "61edec35c270f86928bad434bd059da4efff865d1ef01bcc64ecbd903625dae1"
+S = "${WORKDIR}/gst-plugins-base-${PV}"
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.2.3.bb b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-good_1.2.3.bb
new file mode 100644 (file)
index 0000000..4c01d28
--- /dev/null
@@ -0,0 +1,10 @@
+DEFAULT_PREFERENCE = "-1"
+
+include recipes-multimedia/gstreamer/gstreamer1.0-plugins-good.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
+                    file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \
+                    file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
+SRC_URI[md5sum] = "1a1f96bc27ad446e559474299160a9a8"
+SRC_URI[sha256sum] = "bfb33536a515bdcc34482f64b8d9cc3e47c753878b254923b419bc2f7485e470"
+S = "${WORKDIR}/gst-plugins-good-${PV}"
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.2.3.bb b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly_1.2.3.bb
new file mode 100644 (file)
index 0000000..0ac7721
--- /dev/null
@@ -0,0 +1,9 @@
+DEFAULT_PREFERENCE = "-1"
+
+include recipes-multimedia/gstreamer/gstreamer1.0-plugins-ugly.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
+                    file://tests/check/elements/xingmux.c;beginline=1;endline=21;md5=4c771b8af188724855cb99cadd390068 "
+SRC_URI[md5sum] = "7ae60e2f759f58f32af5fcdc3c9193c4"
+SRC_URI[sha256sum] = "537b0a7607eee499026388bb705b5b68985a3fd59fe22ee09accaf8cdf57eb3b"
+S = "${WORKDIR}/gst-plugins-ugly-${PV}"
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0/0001-Fix-crash-with-gst-inspect.patch b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0/0001-Fix-crash-with-gst-inspect.patch
new file mode 100644 (file)
index 0000000..94f5cc5
--- /dev/null
@@ -0,0 +1,28 @@
+From 6b26f3dbf9bf577d71534ab7410de66d06e46ba2 Mon Sep 17 00:00:00 2001
+From: Carlos Rafael Giani <dv@pseudoterminal.org>
+Date: Sat, 6 Apr 2013 23:52:11 +0200
+Subject: [PATCH] Fix crash with gst-inspect Chris Lord <chris@openedhand.com>
+
+Upstream-Status: Pending
+
+Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org>
+---
+ tools/gst-inspect.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tools/gst-inspect.c b/tools/gst-inspect.c
+index 23b7c44..b79b02e 100644
+--- a/tools/gst-inspect.c
++++ b/tools/gst-inspect.c
+@@ -1556,7 +1556,7 @@ main (int argc, char *argv[])
+   g_option_context_add_main_entries (ctx, options, GETTEXT_PACKAGE);
+   g_option_context_add_group (ctx, gst_init_get_option_group ());
+   if (!g_option_context_parse (ctx, &argc, &argv, &err)) {
+-    g_printerr ("Error initializing: %s\n", err->message);
++    g_printerr ("Error initializing: %s\n", err ? err->message : "(null)");
+     return -1;
+   }
+   g_option_context_free (ctx);
+-- 
+1.8.2
+
diff --git a/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0_1.2.3.bb b/meta-ivi-common/recipes-multimedia/gstreamer/gstreamer1.0_1.2.3.bb
new file mode 100644 (file)
index 0000000..caacc34
--- /dev/null
@@ -0,0 +1,14 @@
+DEFAULT_PREFERENCE = "-1"
+
+include recipes-multimedia/gstreamer/gstreamer1.0.inc
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
+                    file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d"
+
+SRC_URI = " \
+    http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
+    file://0001-Fix-crash-with-gst-inspect.patch \
+    "
+SRC_URI[md5sum] = "8155b9c7574ccaa361cc504e8e0e72dc"
+SRC_URI[sha256sum] = "0f9a9817a384b3448c368c23345e5122435caef9c00f1c40d7b1953827b0d8eb"
+S = "${WORKDIR}/gstreamer-${PV}"