Add joystick.cfg for usb joystick and steering-wheel kernel configure 75/11575/2
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>
Fri, 27 Oct 2017 04:55:01 +0000 (13:55 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sat, 28 Oct 2017 22:12:46 +0000 (22:12 +0000)
    Add joystick.cfg into meta-agl-bsp/recipes-kernel,
    Then include this cfg in each board bbappend.

    Related commit:
        https://gerrit.automotivelinux.org/gerrit/#/c/10463/

Change-Id: Ie484cc8017e7198cefa0d8e7476032c325a8348d
Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/11575
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Thomas Rini <trini@konsulko.com>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc-imx_%.bbappend
meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.9%.bbappend
meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt_4.9.bbappend
meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend
meta-agl-bsp/meta-rcar-gen3/recipes-kernel/linux/linux-renesas_%.bbappend
meta-agl-bsp/meta-renesas/recipes-kernel/linux/linux-renesas_%.bbappend
meta-agl-bsp/meta-ti/recipes-kernel/linux/linux-ti-staging_%.bbappend
meta-agl-bsp/recipes-kernel/linux/linux-%.bbappend
meta-agl-bsp/recipes-kernel/linux/linux/joystick.cfg [new file with mode: 0644]

index bed10fa..da6316a 100644 (file)
@@ -103,3 +103,6 @@ KERNEL_CONFIG_FRAGMENTS_append_smack = "\
 
 # Enable support for usb video class for usb camera devices
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
+
+# Enable support for joystick devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
index 8b490f7..ce600f5 100644 (file)
@@ -11,6 +11,9 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
 # Enable support for usb video class for usb camera devices
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
 
+# Enable support for joystick devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
+
 # Ensure we have a startup.nsh file
 SRC_URI_append = " file://startup.nsh"
 
index 77a1544..8897805 100644 (file)
@@ -30,4 +30,7 @@ KERNEL_CONFIG_FRAGMENTS_append_smack = "\
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/can-bus.cfg"
 
 # Enable support for usb video class for usb camera devices
-KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
\ No newline at end of file
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
+
+# Enable support for joystick devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
index 753440a..3706606 100644 (file)
@@ -106,3 +106,6 @@ PACKAGES += "kernel-module-snd-bcm2835"
 
 # Enable support for usb video class for usb camera devices
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
+
+# Enable support for joystick devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
index c3fb205..460fde3 100644 (file)
@@ -10,3 +10,6 @@ SRC_URI_append  = " file://namespace_fix.cfg \
 
 # Enable support for usb video class for usb camera devices
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
+
+# Enable support for joystick devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
index 0871fbf..8776a84 100755 (executable)
@@ -44,4 +44,7 @@ KERNEL_CONFIG_FRAGMENTS_append_agl-porter-hibernate += " ${WORKDIR}/hibernation/
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/can-bus.cfg"
 
 # Enable support for usb video class for usb camera devices
-KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
\ No newline at end of file
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
+
+# Enable support for joystick devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
index 4acfc9e..6a5f4f4 100644 (file)
@@ -36,3 +36,6 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/can-bus.cfg"
 
 # Enable support for usb video class for usb camera devices
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
+
+# Enable support for joystick devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/joystick.cfg"
index 04aeb94..f64e49a 100644 (file)
@@ -4,4 +4,5 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux:"
 SRC_URI_append = " file://can-bus.cfg \
                    file://usb.cfg \
                    file://uvc.cfg \
+                   file://joystick.cfg \
             "
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux/joystick.cfg b/meta-agl-bsp/recipes-kernel/linux/linux/joystick.cfg
new file mode 100644 (file)
index 0000000..07a145e
--- /dev/null
@@ -0,0 +1,6 @@
+CONFIG_INPUT_JOYDEV=y
+CONFIG_INPUT_JOYSTICK=y
+CONFIG_JOYSTICK_ADI=y
+CONFIG_GAMEPORT=y
+CONFIG_HID_LOGITECH=y
+CONFIG_LOGIWHEELS_FF=y