Extend qemux86-64 images to support real hardware 91/23591/2
authorPaul Barker <pbarker@konsulko.com>
Mon, 20 Jan 2020 15:54:30 +0000 (15:54 +0000)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 21 Jan 2020 22:25:47 +0000 (22:25 +0000)
* Build wic images for qemux86-64 which can be written to a USB stick or
  SD card.

* Support both virtual and physical displays for all qemu targets.

* Use a wks file which works on both virtual and physical machines. EFI
  is now required to boot the VMDK image.

* Drop inclusion of `microcode.cpio` in the boot partition in the wic
  file `systemd-intel-corei7-64-bootdisk.wks`. This file is not
  available for qemux86-64 images and is not strictly necessary.

Bug-AGL: SPEC-2931

Change-Id: Ib3982906e52d3a964a921c9a2234cab697fe0551
Signed-off-by: Paul Barker <pbarker@konsulko.com>
meta-agl-bsp/conf/include/agl_qemux86-64.inc
meta-agl-bsp/meta-aglprofilegraphical/recipes-graphics/wayland/weston-ini-conf.bbappend
meta-agl-bsp/wic/systemd-intel-corei7-64-bootdisk.wks

index a72f7b0..11295c7 100644 (file)
@@ -21,7 +21,7 @@ QB_KERNEL_CMDLINE_APPEND_append = " quiet"
 DISTRO_FEATURES_append = " sota"
 
 # Image support
-AGL_EXTRA_IMAGE_FSTYPES = "ext4 wic.vmdk"
+AGL_EXTRA_IMAGE_FSTYPES = "ext4 wic.vmdk wic.xz wic.bmap"
 IMAGE_BOOT_FILES_sota = "u-boot-qemux86-64.rom"
 
 # Root device
@@ -31,4 +31,4 @@ ROOT_VM = "root=PARTUUID=${DISK_SIGNATURE}-02"
 QB_OPT_APPEND_append = " -vga virtio"
 
 # Use our own wks file
-WKS_FILE="directdisk.wks.in"
+WKS_FILE="systemd-intel-corei7-64-bootdisk.wks"
index 916bd6f..4a2dc80 100644 (file)
@@ -1,12 +1,7 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
-# OVERRIDES save us some c'n'p below ...
-OVERRIDES_prepend_qemux86 = "virtualmachine:"
-OVERRIDES_prepend_qemux86-64 = "virtualmachine:"
-
-# Switch to the Virtual section that we have when a valid DRM device is found
-SRC_URI_remove_virtualmachine = "file://hdmi-a-1-270.cfg"
-SRC_URI_append_virtualmachine = " file://virtual.cfg"
-
-# For intel-corei7-64 we want to support both the HDMI-A-1 and Virtual-1 outputs
+# For virtual machines and intel-corei7-64 we want to support both the HDMI-A-1
+# and Virtual-1 outputs. This allows us to run virtual images on real hardware
+# and vice versa.
+SRC_URI_append_qemuall = " file://virtual.cfg"
 SRC_URI_append_intel-corei7-64 = " file://virtual.cfg"
index 5639372..db46c18 100644 (file)
@@ -3,7 +3,7 @@
 # can directly dd to boot media. The selected bootloader is systemd-boot
 # and we do not have swap
 
-part /boot --source bootimg-efi --sourceparams="loader=systemd-boot,initrd=microcode.cpio" --use-uuid --label msdos --active --align 1024
+part /boot --source bootimg-efi --sourceparams="loader=systemd-boot" --use-uuid --label msdos --active --align 1024
 
 part / --source rootfs --fstype=ext4 --label platform --align 1024 --use-uuid