qemu: add bbappend to tweak PACKAGECONFIG 95/28395/2
authorScott Murray <scott.murray@konsulko.com>
Thu, 19 Jan 2023 00:28:32 +0000 (19:28 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sun, 22 Jan 2023 18:03:09 +0000 (18:03 +0000)
Add a bbappend for qemu to tweak PACKAGECONFIG for target use to add
libusb support.  This is required for USB device passthrough for e.g.
touchscreen support.  Also enable libaio for potential performance
benefits and selinux support for investigation into leveraging it for
security improvement.

Bug-AGL: SPEC-4618

Change-Id: Ib6bc09778b8f93c06c35d2763012b7f6dce99fc9
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28395
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-core/recipes-devtools/qemu/qemu_%.bbappend [new file with mode: 0644]
meta-agl-core/recipes-devtools/qemu/qemu_aglcore.inc [new file with mode: 0644]

diff --git a/meta-agl-core/recipes-devtools/qemu/qemu_%.bbappend b/meta-agl-core/recipes-devtools/qemu/qemu_%.bbappend
new file mode 100644 (file)
index 0000000..9807832
--- /dev/null
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'aglcore', '${BPN}_aglcore.inc', '', d)}
diff --git a/meta-agl-core/recipes-devtools/qemu/qemu_aglcore.inc b/meta-agl-core/recipes-devtools/qemu/qemu_aglcore.inc
new file mode 100644 (file)
index 0000000..77d461a
--- /dev/null
@@ -0,0 +1,5 @@
+PACKAGECONFIG:append = " \
+    aio \
+    libusb \
+    ${@bb.utils.filter('DISTRO_FEATURES', 'selinux', d)} \
+"