security-manager: Restrict socket accesses 72/23872/3
authorJosé Bollo <jose.bollo@iot.bzh>
Thu, 30 Jan 2020 17:13:40 +0000 (18:13 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sat, 15 Feb 2020 22:03:23 +0000 (22:03 +0000)
Ensure that only members of the group and the owner can access
the security manager.

Bug-AGL: SPEC-3146

Change-Id: Ia529be6b4ef425d03be31f0d2e2d623fa6ac091e
Signed-off-by: José Bollo <jose.bollo@iot.bzh>
meta-security/recipes-security/security-manager/security-manager/0015-Restrict-socket-accesses.patch [new file with mode: 0644]
meta-security/recipes-security/security-manager/security-manager_git.bb

diff --git a/meta-security/recipes-security/security-manager/security-manager/0015-Restrict-socket-accesses.patch b/meta-security/recipes-security/security-manager/security-manager/0015-Restrict-socket-accesses.patch
new file mode 100644 (file)
index 0000000..d994919
--- /dev/null
@@ -0,0 +1,34 @@
+From 7cffcd61378a9d7c0e7db5691b2da3a37448c969 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jos=C3=A9=20Bollo?= <jose.bollo@iot.bzh>
+Date: Thu, 30 Jan 2020 09:19:25 +0100
+Subject: [PATCH 15/15] Restrict socket accesses
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Ensure that only members of the group and the owner can access
+the security manager.
+
+Bug-AGL: SPEC-3146
+
+Change-Id: I68ce6523db4bfd4707c3680555c3cb0cf8858ef2
+Signed-off-by: José Bollo <jose.bollo@iot.bzh>
+---
+ systemd/security-manager.socket | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/systemd/security-manager.socket b/systemd/security-manager.socket
+index af1c1da..b401f77 100644
+--- a/systemd/security-manager.socket
++++ b/systemd/security-manager.socket
+@@ -1,6 +1,6 @@
+ [Socket]
+ ListenStream=/run/security-manager.socket
+-SocketMode=0777
++SocketMode=0660
+ SmackLabelIPIn=*
+ SmackLabelIPOut=@
+-- 
+2.21.1
+
index f438ea5..b349735 100644 (file)
@@ -20,6 +20,7 @@ SRC_URI += " \
    file://0012-Avoid-casting-from-const-T-to-void.patch \
    file://0013-Removing-tizen-platform-config.patch \
    file://0014-Ensure-post-install-initialization-of-database.patch \
+   file://0015-Restrict-socket-accesses.patch \
 "
 
 # Use make with cmake and not ninja