meta-agl-profile-graphical-html5: Point Chromium and WAM to agl-compositor 78/25078/2
authorLorenzo Tilve <ltilve@igalia.com>
Fri, 7 Aug 2020 15:54:28 +0000 (17:54 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 11 Aug 2020 16:29:55 +0000 (16:29 +0000)
Updates the branches and revs to the Chromium and WAM repositories
with the ongoing changes to work with the new compositor.
It also depends on the integration of the changes on the
webapps to remove former dependencies, and an additional
fix to properly resume not visible webapps.

Bug-AGL: SPEC-3497

Signed-off-by: Lorenzo Tilve <ltilve@igalia.com>
Change-Id: Iddf1d3675810d718c670a6275b3d1d683461f252
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25078
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-profile-graphical-html5/recipes-wam/chromium/chromium68_git.bb
meta-agl-profile-graphical-html5/recipes-wam/wam/wam_git.bb

index e45f127..d5863d5 100644 (file)
@@ -19,11 +19,11 @@ DEPENDS = "virtual/gettext wayland wayland-native pixman freetype glib-2.0 fontc
 PROVIDES = "${BROWSER_APPLICATION}"
 
 SRC_URI = "\
-    git://github.com/igalia/${PN};branch=@39.agl.jellyfish;protocol=https;rev=${SRCREV_chromium68};name=chromium68 \
+    git://github.com/igalia/${PN};branch=WIP@39.agl.compositor;protocol=https;rev=${SRCREV_chromium68};name=chromium68 \
     git://github.com/webosose/v8;destsuffix=git/src/v8;rev=${SRCREV_v8};name=v8 \
     file://v8-qemu-wrapper.patch \
 "
-SRCREV_chromium68 = "f8a54e973b632d09da232289fddb93fd990ef2f3"
+SRCREV_chromium68 = "ed21537f851045f1a7deb08f17ad59960ca897a3"
 SRCREV_v8 = "1e3af71f1ff3735e8a5b639c48dfca63a7b8a647"
 
 # we don't include SRCPV in PV, so we have to manually include SRCREVs in do_fetch vardeps
index c907c8c..bc5b7ed 100644 (file)
@@ -19,13 +19,13 @@ PROVIDES += "virtual/webruntime"
 RPROVIDES_${PN} += "virtual/webruntime"
 
 SRC_URI = "\
-    git://github.com/igalia/${PN}.git;branch=@6.agl.jellyfish;protocol=https \
+    git://github.com/igalia/${PN}.git;branch=WIP@6.agl.compositor;protocol=https \
     file://WebAppMgr@.service \
     file://WebAppMgr.env \
     file://trunc-webapp-roles.patch \
 "
 S = "${WORKDIR}/git"
-SRCREV = "d012dbe03f23dd87a4e77bd3eec1fe9d227a5085"
+SRCREV = "7fe85fd505f3246e0448bc92348b9b7126ae943c"
 
 do_install_append() {
     install -d ${D}${sysconfdir}/wam