meta-agl-core: add connman-conf dependency 83/27683/3
authorJose Dapena Paz <jdapena@igalia.com>
Tue, 21 Jun 2022 07:48:36 +0000 (09:48 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 28 Jun 2022 21:17:21 +0000 (21:17 +0000)
After kirkstone, connman has an independent package for its
configuration. This package is not added as a dependency.

As a consequence, we do not ship /etc/connman/main.conf, that, in
AGL builds, is expected to provide a fallback for NTP. This means
Raspberry PI4 does not synchronize the clock on boot if connection
is available. As a side effect, all SSL connections fail.

Bug-AGL: SPEC-4447
Change-Id: Iaa34c0a41cd161b0a0edea7602c39f724831412a
Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27683
Reviewed-by: Marius Vlad <marius.vlad@collabora.com>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account

meta-agl-core/recipes-connectivity/connman/connman-conf_aglcore.inc
meta-agl-core/recipes-platform/packagegroups/packagegroup-agl-core-connectivity.bb

index 4505ab7..30a250e 100644 (file)
@@ -1,2 +1,9 @@
 # Pick up our version of main.conf
 FILESEXTRAPATHS:prepend := "${THISDIR}/connman-conf:"
+
+# Upstream connman-conf only installs configuration for qemu targets
+# but we need it in all our BSP
+do_install:append() {
+    mkdir -p ${D}${sysconfdir}/connman
+    cp ${S}/main.conf ${D}${sysconfdir}/connman/main.conf
+}
index 5dd2740..a794d1a 100644 (file)
@@ -12,7 +12,7 @@ ALLOW_EMPTY:${PN} = "1"
 PKGGROUP_ZEROCONF = "${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'packagegroup-base-zeroconf', '', d)}"
 
 RDEPENDS:${PN} += "\
-    ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','connman','connman connman-client connman-tests \
-        connman-tools connman-ncurses' ,'',d)} \
+    ${@bb.utils.contains('VIRTUAL-RUNTIME_net_manager','connman','connman connman-client connman-conf \
+        connman-tests connman-tools connman-ncurses' ,'',d)} \
     ${@bb.utils.contains('AGL_FEATURES', 'agl-devel', '${PKGGROUP_ZEROCONF}', '', d)} \
     "