Add Yocto Project nanbield release compatibility
authorDenys Dmytriyenko <denys@konsulko.com>
Sat, 23 Sep 2023 19:10:05 +0000 (15:10 -0400)
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>
Thu, 7 Mar 2024 12:55:01 +0000 (12:55 +0000)
Switch to nanbield in LAYERSERIES_COMPAT in layer.conf files.

Bug-AGL: SPEC-4578

Change-Id: I11b528374d60caa8c62b95b6ef0c857f35b720f6
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
meta-agl-bsp/conf/layer.conf
meta-agl-bsp/meta-rcar-gen3-adas/conf/layer.conf
meta-agl-core/conf/layer.conf
meta-app-framework/conf/layer.conf
meta-netboot/conf/layer.conf
meta-pipewire/conf/layer.conf

index b9b5d50..f8e8e06 100644 (file)
@@ -23,4 +23,4 @@ BBFILE_COLLECTIONS += "aglbsp"
 BBFILE_PATTERN_aglbsp = "^${LAYERDIR}/"
 BBFILE_PRIORITY_aglbsp = "60"
 
-LAYERSERIES_COMPAT_aglbsp = "kirkstone langdale mickledore"
+LAYERSERIES_COMPAT_aglbsp = "kirkstone langdale mickledore nanbield"
index 95dcaa5..6ff687a 100644 (file)
@@ -15,4 +15,4 @@ BBFILE_COLLECTIONS += "rcar-gen3-cogent"
 BBFILE_PATTERN_rcar-gen3-cogent := "^${LAYERDIR}/"
 BBFILE_PRIORITY_rcar-gen3-cogent = "7"
 
-LAYERSERIES_COMPAT_rcar-gen3-cogent = "kirkstone langdale mickledore"
+LAYERSERIES_COMPAT_rcar-gen3-cogent = "kirkstone langdale mickledore nanbield"
index 6921e41..352bb1e 100644 (file)
@@ -20,7 +20,7 @@ BBFILES_DYNAMIC += " \
     qt5-layer:${LAYERDIR}/dynamic-layers/meta-qt5/*/*/*.bbappend \
 "
 
-LAYERSERIES_COMPAT_aglcore = "kirkstone langdale mickledore"
+LAYERSERIES_COMPAT_aglcore = "kirkstone langdale mickledore nanbield"
 LAYERDEPENDS_aglcore = "core"
 
 # Sanity check for meta-virtualization layer.
index 5417076..6b4a11e 100644 (file)
@@ -9,5 +9,5 @@ BBFILE_COLLECTIONS += "meta-app-framework"
 BBFILE_PATTERN_meta-app-framework = "^${LAYERDIR}/"
 BBFILE_PRIORITY_meta-app-framework = "60"
 
-LAYERSERIES_COMPAT_meta-app-framework = "kirkstone langdale mickledore"
+LAYERSERIES_COMPAT_meta-app-framework = "kirkstone langdale mickledore nanbield"
 LAYERDEPENDS_meta-app-framework = "core aglcore openembedded-layer"
index f890b7d..52d5e0a 100644 (file)
@@ -9,5 +9,5 @@ BBFILE_COLLECTIONS += "meta-netboot"
 BBFILE_PATTERN_meta-netboot = "^${LAYERDIR}/"
 BBFILE_PRIORITY_meta-netboot = "60"
 
-LAYERSERIES_COMPAT_meta-netboot = "kirkstone langdale mickledore"
+LAYERSERIES_COMPAT_meta-netboot = "kirkstone langdale mickledore nanbield"
 LAYERDEPENDS_meta-netboot = "core networking-layer"
index bbbaf02..43abdf0 100644 (file)
@@ -9,7 +9,7 @@ BBFILE_COLLECTIONS += "meta-pipewire"
 BBFILE_PATTERN_meta-pipewire = "^${LAYERDIR}/"
 BBFILE_PRIORITY_meta-pipewire = "71"
 
-LAYERSERIES_COMPAT_meta-pipewire = "kirkstone langdale mickledore"
+LAYERSERIES_COMPAT_meta-pipewire = "kirkstone langdale mickledore nanbield"
 LAYERDEPENDS_meta-pipewire = "openembedded-layer"
 
 #