Add agl-audio-plugin (PulseAudio Routing plugin) 75/6075/2
authorManuel Bachmann <mbc@iot.bzh>
Wed, 8 Jun 2016 13:41:49 +0000 (13:41 +0000)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 15 Jul 2016 12:22:42 +0000 (12:22 +0000)
agl-audio-plugin is a stripped-down version of the former
Tizen IVI Audio Routing plugin (also known as "module-
murphy-ivi"). This is stripped down is the sense that:
- it does not require Murphy anymore;
- it does not implement the most complex use cases anymore;
- it is able to work standalone by using a JSON
configuration file or its own embedded configuration.

It still has the basic structure needed to interconnect an
external policy engine (such as GENIVI AudioManager).

Change-Id: I133916cada5cc928187f2aef6448fdaf7c03c3c6
Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
meta-agl/recipes-multimedia/pulseaudio/agl-audio-plugin_0.1.bb [new file with mode: 0644]
meta-ivi-common/recipes-core/packagegroups/packagegroup-ivi-common-core-multimedia.bb

diff --git a/meta-agl/recipes-multimedia/pulseaudio/agl-audio-plugin_0.1.bb b/meta-agl/recipes-multimedia/pulseaudio/agl-audio-plugin_0.1.bb
new file mode 100644 (file)
index 0000000..8e19b91
--- /dev/null
@@ -0,0 +1,24 @@
+SUMMARY = "AGL Audio Policy Plugin"
+DESCRIPTION = "AGL PulseAudio Routing plugin, forked from the Tizen IVI \
+PulseAudio Routing plugin, also known as module-murphy-ivi. This is a \
+stripped-down version of the former, not needing Murphy anymore and using \
+either a JSON configuration file or its own embedded configuration."
+HOMEPAGE = "http://www.iot.bzh"
+
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
+
+DEPENDS = "json-c pulseaudio"
+RDEPENDS_${PN} = "pulseaudio-server pulseaudio-module-null-sink pulseaudio-module-loopback"
+
+SRCREV = "2d5b809de9d5b69fb9b1ad9e0f3ee5bd53eb2785"
+SRC_URI = "git://github.com/iotbzh/agl-audio-plugin;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+FULL_OPTIMIZATION = "-O1 -pipe ${DEBUG_FLAGS}"
+
+FILES_${PN} += "${libdir}/pulse-6.0/modules/* ${sysconfdir}/pulse/*"
+FILES_${PN}-dbg += "${libdir}/pulse-6.0/modules/.debug/*"