[RCAR] disable a default config in kernel 15/25815/4
authorronan <ronan.lemartret@iot.bzh>
Tue, 15 Dec 2020 20:17:10 +0000 (21:17 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 17 Dec 2020 13:47:06 +0000 (13:47 +0000)
The meta-rcar layer activates by default the configuration MTD_RENESAS_RPC_HYPERFLASH in kernel.
MTD_RENESAS_RPC_HYPERFLASH is not upstream, it's a meta-rcar specific feature.
MTD_RENESAS_RPC_HYPERFLASH feature in the kernel need an firmware update on the board and
can be considered (IMHO) as a security issues in production.

We need to set DISABLE_RPC_ACCESS to deactivate it.

v2 (jsmoeller): Use ?= for DISABLE_RPC_ACCESS .

Bug-AGL: SPEC-3674

Signed-off-by: ronan <ronan.lemartret@iot.bzh>
Change-Id: Iefaf9ca115d1fb805b0d3766fc0c800b74daecee
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25815
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas_%.bbappend

index 36e0caf..def762b 100644 (file)
@@ -24,3 +24,7 @@ KERNEL_DEVICETREE_remove_h3ulcb = " \
     renesas/r8a7795-h3ulcb-4x2g-vb2.1.dtb \
     renesas/r8a7795-h3ulcb-4x2g-vbm.dtb \
 "
+
+# The meta-rcar layer actives by default the configuration MTD_RENESAS_RPC_HYPERFLASH
+# in the kernel. We need to set DISABLE_RPC_ACCESS to deactivate it.
+DISABLE_RPC_ACCESS ?= "1"