Move the agl-service-radio to the graphical profile 54/21554/4
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Sun, 9 Jun 2019 17:58:25 +0000 (19:58 +0200)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Sat, 22 Jun 2019 22:38:53 +0000 (00:38 +0200)
The agl-service-radio relies on gstreamer. Unfortunately the gstreamer recipe is currently
setup to also pull-in wayland (due to a compile-flag if wayland is in DISTRO_FEATURES).

To keep the distro aligned, we don't want to change the DISTRO_FEATURES between the profiles, thus we
move the agl-service radio to the graphical profile where we include weston anyway by default.

For now this means there is no radio service (or mediaplayer service) w/o wayland installed as well.
In case we get this requirement, we'll have to work on the gstreamer recipe and its split.

v2: fix bbapend in meta-agl-bsp/meta-rcar-gen3
v3: put packagegroup-agl-graphical-multimedia.bbappend in graphical profile (not the best place IMHO)
    This fixes the non-graphical build.

Bug-AGL: SPEC-2500

Change-Id: I5ebec7d7713510f3fcd50ae425d7f8cbb6328016
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-services.bb
meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-image-minimal.bb
meta-agl-profile-graphical/recipes-apis/agl-service-radio/agl-service-radio_git.bb [moved from meta-agl-profile-core/recipes-apis/agl-service-radio/agl-service-radio_git.bb with 100% similarity]
meta-agl-profile-graphical/recipes-multimedia/gstreamer1.0-plugins-good/gstreamer1.0-plugins-good_%.bbappend [moved from meta-agl-profile-core/recipes-multimedia/gstreamer1.0-plugins-good/gstreamer1.0-plugins-good_%.bbappend with 100% similarity]
meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-multimedia.bb [moved from meta-agl-profile-core/recipes-platform/packagegroups/packagegroup-agl-core-multimedia.bb with 87% similarity]
meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-multimedia.bbappend [moved from meta-agl-bsp/meta-rcar-gen3/recipes-core/packagegroups/packagegroup-agl-core-multimedia.bbappend with 90% similarity]
meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-graphical-services.bb
meta-agl-profile-graphical/recipes-platform/packagegroups/packagegroup-agl-profile-graphical.bb

index 6e8ad82..82cfb3a 100644 (file)
@@ -24,7 +24,6 @@ agl-service-mediascanner \
 agl-service-navigation \
 agl-service-network \
 agl-service-nfc \
-${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'agl-service-radio', '', d)} \
 agl-service-signal-composer \
 agl-service-steering-wheel \
 agl-service-unicens \
index fb784d5..383b144 100644 (file)
@@ -19,7 +19,6 @@ RDEPENDS_${PN} += "\
 RDEPENDS_${PN} += "\
     packagegroup-agl-core-connectivity \
     packagegroup-agl-core-navigation \
-    packagegroup-agl-core-multimedia \
     packagegroup-agl-core-os-commonlibs \
     packagegroup-agl-core-services \
     packagegroup-agl-core-security \
@@ -1,4 +1,4 @@
-RDEPENDS_${PN} += "\
+RDEPENDS_${PN}_append_ulcb     = "\
        ${@bb.utils.contains('MACHINE_FEATURES','multimedia','packagegroup-multimedia-kernel-modules','',d)} \
        ${@bb.utils.contains('MACHINE_FEATURES','multimedia','packagegroup-multimedia-libs','',d)} \
        ${@bb.utils.contains('MACHINE_FEATURES','multimedia','packagegroup-gstreamer1.0-plugins','',d)} \
index b80089a..2ebb3d6 100644 (file)
@@ -10,5 +10,6 @@ PACKAGES = "\
 ALLOW_EMPTY_${PN} = "1"
 
 RDEPENDS_${PN} += "\
-agl-service-mediaplayer \
+${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'agl-service-mediaplayer', '', d)} \
+${@bb.utils.contains('DISTRO_FEATURES', 'pipewire', 'agl-service-radio', '', d)} \
     "
index ced2b53..406ebcd 100644 (file)
@@ -15,6 +15,7 @@ RDEPENDS_${PN} += "\
     packagegroup-agl-image-minimal \
     packagegroup-agl-graphical-weston \
     packagegroup-agl-graphical-services \
+    packagegroup-agl-graphical-multimedia \
 "
 # FIXME: Removed due to issues building against weston 5.0.0:
 #    waltham-transmitter