Add rpi network drivers by default 90/20990/1
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Thu, 11 Apr 2019 11:47:10 +0000 (13:47 +0200)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Thu, 11 Apr 2019 11:47:10 +0000 (13:47 +0200)
This is needed for network booting.

Change-Id: Iecee73a3b0bf31c3c68bb4beea1f41d07c9b5ec5
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/raspberrypi_network.cfg [new file with mode: 0644]
meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_%.bbappend

diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/raspberrypi_network.cfg b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/raspberrypi_network.cfg
new file mode 100644 (file)
index 0000000..aa96490
--- /dev/null
@@ -0,0 +1,5 @@
+
+CONFIG_USB_NET_SMSC95XX=y
+CONFIG_NETDEVICES=y
+CONFIG_USB_NET_DRIVERS=y
+CONFIG_USB_USBNET=y
index 92dd6e7..4271926 100644 (file)
@@ -35,3 +35,7 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-panel.cfg"
 # Enable bt hci uart
 SRC_URI_append = " file://raspberrypi-hciuart.cfg"
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi-hciuart.cfg"
+
+# ENABLE NETWORK (built-in)
+SRC_URI_append = " file://raspberrypi_network.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/raspberrypi_network.cfg"