Remove use of AGL_APP_REVISION 93/27693/2
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 29 Jun 2022 18:21:59 +0000 (20:21 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 29 Jun 2022 20:26:20 +0000 (20:26 +0000)
We did use the variable AGL_APP_REVISION to change between the HEAD of the branch
via  to the fixed tag at release time (regs/tags/xyz) .

While this worked well previously, it turns out that bitbake will query git every time
it runs for either  or tags likewise. For tags it cannot trust whatever is known locally
is actually the latest tags as there can be force pushed tags.

To fix this we use a well-defined SRCREV for apps/* in the same way
as we do it for src/* .

Bug-AGL: SPEC-4455
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Change-Id: I54bad2ef6c8b171b1ae1270b4adb951fb180b260
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27693
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account

meta-agl-core/conf/distro/poky-agl.conf
meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb

index e13ce6f..02f1b7e 100644 (file)
@@ -9,25 +9,24 @@ DISTRO_NAME = "Automotive Grade Linux"
 DISTRO_CODENAME = "needlefish"
 AGL_BRANCH = "master"
 AGLVERSION = "13.90.0"
+
 # switch  devel/release
 AGLRELEASETYPE ?= "agldevelopment"
-#AGLRELEASETYPE ?= "aglrelease"
+#AGLRELEASETYPE = "aglrelease"
+
 OVERRIDES .= ":${AGLRELEASETYPE}"
-#
+
 
 #for development
 DISTRO_VERSION:agldevelopment := "${AGLVERSION}+snapshot-${METADATA_REVISION}"
-AGL_APP_REVISION:agldevelopment = "${AUTOREV}"
-AGL_DEFAULT_REVISION:agldevelopment = "${AUTOREV}"
 
 #for release
 DISTRO_VERSION:aglrelease := "${AGLVERSION}"
 DISTRO_BRANCH_VERSION_TAG = "${DISTRO_CODENAME}/${@'${DISTRO_VERSION}'.replace('+snapshot-${METADATA_REVISION}','')}"
-AGL_APP_REVISION:aglrelease := "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
-AGL_DEFAULT_REVISION:aglrelease := "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
 
 # reproducible builds:
 # Set the desired timestamps
+# E.g. update for (major) releases
 export SOURCE_DATE_EPOCH = "1593400000"
 REPRODUCIBLE_TIMESTAMP_ROOTFS = "1593400000"
 
index d588868..2457b67 100644 (file)
@@ -15,7 +15,7 @@ PV      = "1.0+git${SRCPV}"
 SRC_URI = " \
         git://gerrit.automotivelinux.org/gerrit/src/applaunchd;protocol=https;branch=${AGL_BRANCH}  \
         "
-SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "c84836ec5ddaf2d0e91c46713475c35652bb540f"
 
 S       = "${WORKDIR}/git"