meta-intel: Support the upsquare board 93/21193/1
authorCorentin Labbe <clabbe@baylibre.com>
Mon, 29 Apr 2019 13:59:08 +0000 (13:59 +0000)
committerCorentin Labbe <clabbe@baylibre.com>
Mon, 29 Apr 2019 13:59:50 +0000 (13:59 +0000)
This patch adds the necessary CONFIG for booting the upsquare board.

The upsquare have an R8169 ethernet card and need it built-in for the kernel DHCP autoconf to work.
The upsquare need some MFD_INTEL configs to boot.
The meta-intel miss some CONFIG necessary for LAVA and NBD to works.

Bug-AGL: SPEC-2075

Change-Id: Iad63e0f0b978bb75f8d8759ad353e7952b63a2ab
Signed-off-by: Corentin Labbe <clabbe@baylibre.com>
meta-agl-bsp/meta-intel/recipes-kernel/linux/files/lava.cfg [new file with mode: 0644]
meta-agl-bsp/meta-intel/recipes-kernel/linux/files/net-devices.cfg
meta-agl-bsp/meta-intel/recipes-kernel/linux/files/upsquare.cfg [new file with mode: 0644]
meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-intel_4.19%.bbappend

diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/lava.cfg b/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/lava.cfg
new file mode 100644 (file)
index 0000000..4dcf403
--- /dev/null
@@ -0,0 +1,3 @@
+CONFIG_BLK_DEV_RAM=y
+CONFIG_BLK_DEV_NBD=y
+CONFIG_BLK_DEV_INITRD=y
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/upsquare.cfg b/meta-agl-bsp/meta-intel/recipes-kernel/linux/files/upsquare.cfg
new file mode 100644 (file)
index 0000000..7be178b
--- /dev/null
@@ -0,0 +1,4 @@
+CONFIG_MFD_CORE=y
+CONFIG_MFD_INTEL_LPSS=y
+CONFIG_MFD_INTEL_LPSS_ACPI=y
+CONFIG_MFD_INTEL_LPSS_PCI=y
index c49b8ec..9827b3e 100644 (file)
@@ -12,6 +12,14 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
 SRC_URI_append = " file://net-devices.cfg"
 KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/net-devices.cfg"
 
+# adding specific driver needed by the upsquare board
+SRC_URI_append = " file://upsquare.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/upsquare.cfg"
+
+# adding CONFIG needed by LAVA and NBD
+SRC_URI_append = " file://lava.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/lava.cfg"
+
 # Ensure we have a startup.nsh file
 SRC_URI_append = " file://startup.nsh"