meta-agl-bsp: Enable building agl-refhw-h3 firmware 22/26522/2
authorScott Murray <scott.murray@konsulko.com>
Thu, 1 Jul 2021 17:11:46 +0000 (13:11 -0400)
committerScott Murray <scott.murray@konsulko.com>
Fri, 23 Jul 2021 20:15:04 +0000 (20:15 +0000)
Changes:
- Replace the agl-refhw-h3 addition to MACHINEOVERRIDES with just
  using AGL_FEATURES.  With the rework of the arm-trusted-firmware
  bbappend in meta-agl-refhw, the override is no longer necessary,
  and a feature in AGL_FEATURES makes more sense in the context of
  this not being a separate machine in the AGL build, but just a
  feature.
- Remove BBMASK so the arm-trusted-firmware bbappend from
  meta-agl-refhw-gen3 will now be picked up.
- Hook up building the U-Boot variant for the refhw by extending
  UBOOT_CONFIG.
- Remove the compatible machine declaration from gpsd-conf-refhw,
  as we're using the package in h3ulcb images anyways.

Bug-AGL: SPEC-3916

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: Ibe3ecdbe74811793c0e030df28a64b3052d64f47
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26476
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
(cherry picked from commit bc4666c43c67a666e1cf6706b601b397fd0f5548)
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26522
Tested-by: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account

meta-agl-bsp/conf/include/agl_refhw-h3.inc
meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-conf-refhw_1.0.bb

index a22a1ec..96e7269 100644 (file)
@@ -1,10 +1,9 @@
-MACHINEOVERRIDES_append = ":agl-refhw-h3"
+AGL_FEATURES_append = " agl-refhw-h3"
 
 # Reference hardware has USB3
 MACHINE_FEATURES_append = " usb3"
 
 KERNEL_DEVICETREE_append = " renesas/r8a7795-agl-refhw.dtb"
 
-# Disable the meta-agl-refhw-gen3 arm-trusted-firmware bbappend as
-# it makes the firmware reference hardware specific.
-BBMASK += "meta-agl-refhw-gen3/recipes-bsp/arm-trusted-firmware"
+UBOOT_CONFIG_append = " agl-refhw-4x2g"
+UBOOT_CONFIG[agl-refhw-4x2g] = "r8a7795_salvator-xs-4x2g_defconfig"
index c87308e..048b235 100644 (file)
@@ -2,7 +2,6 @@ SUMMARY = "AGL Reference Hardware specific gpsd configuration"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
 
-COMPATIBLE_MACHINE = "agl-refhw-h3"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 SRC_URI = "file://gpsd.refhw \