Fix the -nogfx builds for the YP 3.1.4 uprev 28/25728/2
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 4 Dec 2020 05:49:22 +0000 (06:49 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 4 Dec 2020 13:50:03 +0000 (13:50 +0000)
This fixes
Missing or unbuildable dependency chain was: ['agl-image-minimal-crosssdk', 'waltham-dev']

Bug-AGL: SPEC-3706
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Change-Id: Ic80bf6cac57b53edda112f38a92884ed8506d74d
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25728
Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>
ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org>

meta-agl-bsp/conf/include/agl_h3ulcb-nogfx.inc
meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc
meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.inc

index 25755d2..70bc68b 100644 (file)
@@ -8,3 +8,6 @@ DTB_SUFFIX = "r8a7795-h3ulcb"
 BBMASK += "gles-user-module|kernel-module-gles|wayland-kms|libgbm"
 # Mask MMP recipes
 BBMASK += "kernel-module-uvcs-drv|omx-user-module"
+
+# Workaround for SPEC-3706 - versioned bbappends and upstream moved on to 1.16.3
+BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-.*1.16.2\.bbappend"
index 5092c4b..28360fc 100644 (file)
@@ -12,3 +12,5 @@ BBMASK += "kernel-module-uvcs-drv|omx-user-module"
 DISTRO_FEATURES_append = "${@bb.utils.contains('AGL_XEN_WANTED', '1', ' xen', '', d)}"
 IMAGE_INSTALL_append = "${@bb.utils.contains('AGL_XEN_WANTED', '1', ' xen-base xen-mkimage', '', d)}"
 
+# Workaround for SPEC-3706 - versioned bbappends and upstream moved on to 1.16.3
+BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-.*1.16.2\.bbappend"
index e68e8db..7181294 100644 (file)
@@ -15,5 +15,4 @@ TOOLCHAIN_TARGET_TASK += " \
     lua-staticdev \
     libafb-helpers-staticdev \
     libappcontroller-staticdev \
-    waltham-dev \
     "