Add new recipe for Interbench 65/5465/3
authorYannick Gicquel <yannick.gicquel@iot.bzh>
Thu, 31 Mar 2016 14:59:46 +0000 (16:59 +0200)
committerGerrit Code Review <gerrit@172.30.200.200>
Sat, 9 Apr 2016 04:12:14 +0000 (04:12 +0000)
Change-Id: Ie8f4402a7877714db06858abef0a57869f7ae803
Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh>
meta-ivi-common/recipes-test/interbench/interbench_0.31.bb [new file with mode: 0644]

diff --git a/meta-ivi-common/recipes-test/interbench/interbench_0.31.bb b/meta-ivi-common/recipes-test/interbench/interbench_0.31.bb
new file mode 100644 (file)
index 0000000..eca0e85
--- /dev/null
@@ -0,0 +1,27 @@
+DESCRIPTION = "The Linux interactivity benchmark"
+HOMEPAGE = "http://users.tpg.com.au/ckolivas/interbench/"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
+SRC_URI = "http://ck.kolivas.org/apps/interbench/interbench-${PV}.tar.bz2"
+
+inherit autotools
+
+B = "${S}"
+EXTRA_OEMAKE = "CC='${CC}'"
+
+# upstream tarball contains x86_64 binaries, we need a clean source tree
+do_compile() {
+    oe_runmake clean
+    oe_runmake
+}
+
+do_install() {
+    install -d ${D}${bindir} ${D}${datadir}/doc/${PN}/ ${D}${mandir}/man8/
+    install -m 0755 ${B}/interbench ${D}${bindir}
+    install -m 0644 ${S}/readme* ${D}${datadir}/doc/${PN}/
+    install -m 0644 ${S}/interbench.8 ${D}${mandir}/man8/
+}
+
+SRC_URI[md5sum] = "832254d7fd1255c548ebea7b97f01015"
+SRC_URI[sha256sum] = "89d438b28aef22d26e79812762a57a9f9344a8dd8826edebfe60dad48ee1c784"
+